summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-21 10:19:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-21 10:19:30 +0000
commitf9f1a8c80671b4b1944226c84a5197183384a2ba (patch)
treeeede73aca44e68cec24e0949b6ab16c232ced490 /dev-libs/jemalloc
parentdev-libs/gobject-introspection: stable 1.66.1 for hppa, bug #774927 (diff)
downloadgentoo-f9f1a8c80671b4b1944226c84a5197183384a2ba.tar.gz
gentoo-f9f1a8c80671b4b1944226c84a5197183384a2ba.tar.bz2
gentoo-f9f1a8c80671b4b1944226c84a5197183384a2ba.zip
dev-libs/jemalloc: drop USE=hardened option
The only effect of USE=hardened was to pass a --disable-syscall configure option. It's only effect is to use library wrappers to memory allocation instead of direct syscalls to kernel. As jemalloc overrides a bunch of library memory allocation library calls itself this introduces extra chances to interact badly with other tool that override library calls. In #617518 sandbox became incompatible with jemalloc users and produced deadlocks. Example from ruby[jemalloc]: malloc_init() [called by jemalloc] -> open("/proc/sys/vm/overcommit_memory") -> [sandbox takes over] open_DEFAULT() -> [sandbox initializes] -> init_env_entries () -> _xmalloc() -> sb_mmap() [ try hard not to use olerloaded mmap() ] -> get_dlsym("mmap") -> calloc() [ sandbox loses control, overridden by jemalloc ] -> malloc_init() [ recursion, gets locked in attempt to lock again locked malloc_init mutex ] There should be no reason to use --disable-syscall on linux. And especially not under generic (and enabled by default on hardened profiles) USE=hardened. The change drops --disable-syscall passing (and USE=hardened) completely. Users still can do it via EXTRA_ECONF= but there should be no need for that. Upstream ./configure should do the right thing. Reported-by: Maciej Piechotka Closes: https://bugs.gentoo.org/617518 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/jemalloc-5.2.1-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/jemalloc/jemalloc-5.2.1-r1.ebuild b/dev-libs/jemalloc/jemalloc-5.2.1-r1.ebuild
new file mode 100644
index 000000000000..e66e9eae5177
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-5.2.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools toolchain-funcs multilib-minimal
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://jemalloc.net/ https://github.com/jemalloc/jemalloc"
+SRC_URI="https://github.com/jemalloc/jemalloc/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE="debug lazy-lock prof static-libs stats xmalloc"
+HTML_DOCS=( doc/jemalloc.html )
+PATCHES=( "${FILESDIR}/${PN}-5.2.0-gentoo-fixups.patch" )
+
+MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable debug) \
+ $(use_enable lazy-lock) \
+ $(use_enable prof) \
+ $(use_enable stats) \
+ $(use_enable xmalloc)
+}
+
+multilib_src_install() {
+ # Copy man file which the Makefile looks for
+ cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fixup install_name, #437362
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
+ fi
+ use static-libs || find "${ED}" -name '*.a' -delete
+}