summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-12 21:50:14 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-12 22:51:45 -0500
commit8f7f617c10c6ea4a03a4725a27dc74e95822bed5 (patch)
tree7aa5a6ed5a44fe49edcf9382290b0bad414712c1 /dev-libs/jsonrpc-glib
parentdev-libs/json-glib: Version bump to 1.6.2 (diff)
downloadgentoo-8f7f617c10c6ea4a03a4725a27dc74e95822bed5.tar.gz
gentoo-8f7f617c10c6ea4a03a4725a27dc74e95822bed5.tar.bz2
gentoo-8f7f617c10c6ea4a03a4725a27dc74e95822bed5.zip
dev-libs/jsonrpc-glib: Version bump to 3.38.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/jsonrpc-glib')
-rw-r--r--dev-libs/jsonrpc-glib/Manifest1
-rw-r--r--dev-libs/jsonrpc-glib/jsonrpc-glib-3.38.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/jsonrpc-glib/Manifest b/dev-libs/jsonrpc-glib/Manifest
index 954e85d687e6..dd16f4cc8768 100644
--- a/dev-libs/jsonrpc-glib/Manifest
+++ b/dev-libs/jsonrpc-glib/Manifest
@@ -1 +1,2 @@
DIST jsonrpc-glib-3.34.0.tar.xz 41792 BLAKE2B 2be0d690e3ead57a7ad71b93d13ad28e23c96d89d36373d93ba608c4ea2aeed3684862938cfb64675cfcba84d9804f6352b877e343ac2af5aed8b2d4b39854f8 SHA512 58908dd11f7848b09e63f7a7ff2185d0742c049ddffb033e768f783bcbcda7e75a658bec923372212694431b25b0fb894e3ea37ce2d7c52c99e49fd230319c10
+DIST jsonrpc-glib-3.38.0.tar.xz 42224 BLAKE2B d7caf3dc116c43d652009ce646c0b837bd8a2a1b4d2b60ba49e9d746ff5e36e4c91fe5f4b5542a4562e6c8f13130d00fd22b57777d0e5ffd6e5b46f817f4dcb4 SHA512 1862403c37b7140e91720264a1b00a408b969f0464fc022a5c24be0eea993526d118ece6611927e1309071c3db9d3d6bf9f13ae8ed23ff1d34f36fb68c2584cd
diff --git a/dev-libs/jsonrpc-glib/jsonrpc-glib-3.38.0.ebuild b/dev-libs/jsonrpc-glib/jsonrpc-glib-3.38.0.ebuild
new file mode 100644
index 000000000000..0029319a3d8b
--- /dev/null
+++ b/dev-libs/jsonrpc-glib/jsonrpc-glib-3.38.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala
+
+DESCRIPTION="JSON-RPC library for GLib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/jsonrpc-glib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk-doc +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib[introspection?]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-util/glib-utils
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_profiling=false # -pg passing
+ $(meson_use introspection with_introspection)
+ $(meson_use vala with_vapi)
+ $(meson_use gtk-doc enable_gtk_doc)
+ $(meson_use test enable_tests)
+ )
+ meson_src_configure
+}