summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-13 10:31:56 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-13 10:36:02 -0600
commit92145516758facd44002ff6a545b2aa4e66935cf (patch)
tree76086ef45fa3a679f2d0e6696d7cb038d07fb10b /dev-libs/leatherman/leatherman-1.10.0.ebuild
parentx11-wm/openbox: Python 3 support. (diff)
downloadgentoo-92145516758facd44002ff6a545b2aa4e66935cf.tar.gz
gentoo-92145516758facd44002ff6a545b2aa4e66935cf.tar.bz2
gentoo-92145516758facd44002ff6a545b2aa4e66935cf.zip
dev-libs/leatherman: 1.10.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman/leatherman-1.10.0.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-1.10.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/leatherman/leatherman-1.10.0.ebuild b/dev-libs/leatherman/leatherman-1.10.0.ebuild
new file mode 100644
index 000000000000..ac093ea96d57
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.10.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54:=[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if ! use static-libs; then
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=ON
+ )
+ else
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=OFF
+ )
+ fi
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}