summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-11 13:15:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-11 13:21:03 -0500
commit8a02e348451b30be7a3ba2fe68b7438e5409b1d6 (patch)
tree830d752f53c8168744757db0bd3fee2c06f76c51 /dev-libs/leatherman/leatherman-1.12.1.ebuild
parentnet-misc/ntpsec: arm64 stable (bug #732234) (diff)
downloadgentoo-8a02e348451b30be7a3ba2fe68b7438e5409b1d6.tar.gz
gentoo-8a02e348451b30be7a3ba2fe68b7438e5409b1d6.tar.bz2
gentoo-8a02e348451b30be7a3ba2fe68b7438e5409b1d6.zip
dev-libs/leatherman: 1.12.1 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman/leatherman-1.12.1.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-1.12.1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/leatherman/leatherman-1.12.1.ebuild b/dev-libs/leatherman/leatherman-1.12.1.ebuild
new file mode 100644
index 000000000000..9a442087026a
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.12.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.73:=[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ # vendored boost lib conflicts with boost 1.73 and above
+ sed -i '/nowide/d' CMakeLists.txt
+ sed -i '/nowide/d' file_util/CMakeLists.txt || die
+ sed -i '/nowide/d' windows/CMakeLists.txt || die
+ sed -i '/nowide/d' execution/CMakeLists.txt || die
+ sed -i '/nowide/d' logging/CMakeLists.txt || die
+ sed -i '/nowide/d' util/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ )
+ if ! use static-libs; then
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=ON
+ )
+ else
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=OFF
+ )
+ fi
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}