summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-21 12:58:13 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2019-04-24 18:30:16 -0400
commit06925b0633e16fcd92fbfdaf390a00bdecbaec0d (patch)
tree7fce080d2b63713112dd9ee2d7d0e8c532b71367 /dev-libs/libaio
parentsys-firmware/intel-microcode: drop old (diff)
downloadgentoo-06925b0633e16fcd92fbfdaf390a00bdecbaec0d.tar.gz
gentoo-06925b0633e16fcd92fbfdaf390a00bdecbaec0d.tar.bz2
gentoo-06925b0633e16fcd92fbfdaf390a00bdecbaec0d.zip
dev-libs/libaio: Bump to version 0.3.111
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-libs/libaio')
-rw-r--r--dev-libs/libaio/Manifest1
-rw-r--r--dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch30
-rw-r--r--dev-libs/libaio/libaio-0.3.111.ebuild87
3 files changed, 118 insertions, 0 deletions
diff --git a/dev-libs/libaio/Manifest b/dev-libs/libaio/Manifest
index 4bb3d6301738..56396318f01e 100644
--- a/dev-libs/libaio/Manifest
+++ b/dev-libs/libaio/Manifest
@@ -1 +1,2 @@
DIST libaio-0.3.110.tar.gz 42270 BLAKE2B e774e5888106ffcf4db08569a8b3dc6722f4e0e8278e9f2fafe865e282c0568059e8dbb37aab7a33719ab4d80f42404bfb1d4ab03f5c066d9eb75301676f525e SHA512 664295d330d6e9adc005e2331e77582619625b479ffc2b81728ba6a682487380ee936079c4a69d35144b458bbe35c612f4ed9b32e913bd7e109b824345763eb3
+DIST libaio-0.3.111.tar.gz 44557 BLAKE2B dc2f44599218de0ca80cfc17f604eb85c9b1241ce7221f49f1a4ee8c5bd3fa135c29ac8d97f6f97550a508e27b0dc92eb709256ffd803c1feca255016a4d674d SHA512 259b89647e22ba47edd4076b8d6aa8ab89af197b64930aa5b01b69fc1969b13b4a5e91c449ccdc9b2746c9eae3160211ce1fe110d252efeca5f2c56d0ea66e2e
diff --git a/dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch b/dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch
new file mode 100644
index 000000000000..5b6f91e56d98
--- /dev/null
+++ b/dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch
@@ -0,0 +1,30 @@
+From ebe62b178f3e5fcde8a311e64aaffe62099204a5 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 21 Apr 2019 12:44:26 +0200
+Subject: [PATCH] make -Werror into an optional flag
+
+This lets distros disable the flag as random errors might come up with
+different compiler flags and older/newer toolchain versions.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ harness/Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/harness/Makefile b/harness/Makefile
+index f477737..a155c4b 100644
+--- a/harness/Makefile
++++ b/harness/Makefile
+@@ -6,7 +6,8 @@ PROGS:=$(PARTPROGS) $(EXTRAPROGS)
+ HARNESS_SRCS:=main.c
+ # io_queue.c
+
+-CFLAGS+=-Wall -Werror -I../src -g -O2 -DPAGE_SIZE=$(shell getconf PAGESIZE)
++CFLAGS_WERROR?=-Werror
++CFLAGS+=-Wall $(CFLAGS_WERROR) -I../src -g -O2 -DPAGE_SIZE=$(shell getconf PAGESIZE)
+ #-lpthread -lrt
+
+ all: $(PROGS)
+--
+2.21.0
+
diff --git a/dev-libs/libaio/libaio-0.3.111.ebuild b/dev-libs/libaio/libaio-0.3.111.ebuild
new file mode 100644
index 000000000000..1f25348ff600
--- /dev/null
+++ b/dev-libs/libaio/libaio-0.3.111.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs flag-o-matic
+
+DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
+HOMEPAGE="https://pagure.io/libaio"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://pagure.io/libaio.git"
+else
+ SRC_URI="https://pagure.io/${PN}/archive/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="static-libs test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.109-install.patch
+ "${FILESDIR}"/${PN}-0.3.110-cppflags.patch
+ "${FILESDIR}"/${PN}-0.3.111-optional-werror.patch
+ "${FILESDIR}"/${PN}-0.3.110-link-stdlib.patch #558406
+)
+
+src_prepare() {
+ default
+
+ local sed_args=(
+ -e "/^prefix=/s:/usr:${EPREFIX}/usr:"
+ -e '/^libdir=/s:lib$:$(ABI_LIBDIR):'
+ )
+ if ! use static-libs; then
+ sed_args+=( -e '/\tinstall .*\/libaio.a/d' )
+ # Tests require the static library to be built.
+ use test || sed_args+=( -e '/^all_targets +=/s/ libaio.a//' )
+ fi
+ sed -i "${sed_args[@]}" src/Makefile Makefile || die
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ if use arm ; then
+ # When building for thumb, we can't allow frame pointers.
+ # http://crbug.com/464517
+ if $(tc-getCPP) ${CFLAGS} ${CPPFLAGS} - <<<$'#ifndef __thumb__\n#error\n#endif' >&/dev/null ; then
+ append-flags -fomit-frame-pointer
+ fi
+ fi
+}
+
+_emake() {
+ CC=$(tc-getCC) \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB) \
+ ABI_LIBDIR=$(get_libdir) \
+ CFLAGS_WERROR= \
+ emake "$@"
+}
+
+multilib_src_compile() {
+ _emake
+}
+
+multilib_src_test() {
+ mkdir -p testdir || die
+ # 'make check' breaks with sandbox, 'make partcheck' works
+ _emake partcheck prefix="${S}/src" libdir="${S}/src"
+}
+
+multilib_src_install() {
+ _emake install DESTDIR="${D}"
+}
+
+multilib_src_install_all() {
+ doman man/*
+ dodoc ChangeLog TODO
+
+ # move crap to / for multipath-tools #325355
+ gen_usr_ldscript -a aio
+
+ # This lib is a bare minimal shim on top of kernel syscalls.
+ export QA_DT_NEEDED=$(find "${ED}" -type f -name 'libaio.so.*' -printf '/%P\n')
+}