summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libappindicator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libappindicator')
-rw-r--r--dev-libs/libappindicator/Manifest1
-rw-r--r--dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch72
-rw-r--r--dev-libs/libappindicator/libappindicator-12.10.0-r1.ebuild59
-rw-r--r--dev-libs/libappindicator/libappindicator-12.10.0-r200.ebuild78
-rw-r--r--dev-libs/libappindicator/libappindicator-12.10.0-r300.ebuild66
-rw-r--r--dev-libs/libappindicator/metadata.xml11
6 files changed, 287 insertions, 0 deletions
diff --git a/dev-libs/libappindicator/Manifest b/dev-libs/libappindicator/Manifest
new file mode 100644
index 000000000000..762d87cf6297
--- /dev/null
+++ b/dev-libs/libappindicator/Manifest
@@ -0,0 +1 @@
+DIST libappindicator-12.10.0.tar.gz 535562 SHA256 d5907c1f98084acf28fd19593cb70672caa0ca1cf82d747ba6f4830d4cc3b49f SHA512 317a22a23c8ed84e74207b64b2e9683992d1fb7208176637a051dfe925974f966d1cfa31e650b45eaf839ab61641dee8fbebc8a07882a09b0dd766d88b8d5b9a WHIRLPOOL fdf1d3afbe82d287da688295e6f999656a4dd8e0a1c75aeffa9fd83c69b97cfd37e682f0ca4aff42d30e99b0add8a9e75f870d8a6a72e5337e1afd67ffe618eb
diff --git a/dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch b/dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch
new file mode 100644
index 000000000000..6a5e15f3c0b1
--- /dev/null
+++ b/dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch
@@ -0,0 +1,72 @@
+--- bindings/Makefile.am 2015-07-10 10:04:18.091199191 +0200
++++ bindings/Makefile.am 2015-07-10 10:19:47.047974439 +0200
+@@ -3,8 +3,10 @@
+ vala
+ else
+ SUBDIRS = \
+- python \
+ vala
++if HAS_PYTHON
++SUBDIRS += python
++endif
+ endif
+
+ if HAS_MONO
+--- configure.ac 2015-07-16 13:28:41.007502838 +0200
++++ configure.ac_new 2015-07-16 13:53:18.118602877 +0200
+@@ -188,25 +188,37 @@
+ PYGTK_REQUIRED=2.14.0
+ PYGOBJECT_REQUIRED=0.22
+
+-AM_PATH_PYTHON(2.3.5)
+-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
++AC_ARG_ENABLE([python],
++ AC_HELP_STRING([--enable-python], [Enable python for GTK2 build]),,
++ [enable_python=yes])
+
+-PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
++if test x"$with_gtk" = x"3" ; then
++ enable_python=no
++fi
++
++AM_CONDITIONAL(HAS_PYTHON, test x"${enable_python}" != x"no")
++
++if test x"$enable_python" != x"no" ; then
++ AM_PATH_PYTHON(2.3.5)
++ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
++
++ PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
+ [
+ pygtk-2.0 >= $PYGTK_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ pygobject-2.0 >= $PYGOBJECT_REQUIRED
+ ])
+
+-AC_MSG_CHECKING(for pygtk defs)
+-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
+-AC_SUBST(PYGTK_DEFSDIR)
+-AC_MSG_RESULT($PYGTK_DEFSDIR)
+-
+-AC_MSG_CHECKING(for pygtk codegen)
+-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+-AC_SUBST(PYGTK_CODEGEN)
+-AC_MSG_RESULT($PYGTK_CODEGEN)
++ AC_MSG_CHECKING(for pygtk defs)
++ PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
++ AC_SUBST(PYGTK_DEFSDIR)
++ AC_MSG_RESULT($PYGTK_DEFSDIR)
++
++ AC_MSG_CHECKING(for pygtk codegen)
++ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
++ AC_SUBST(PYGTK_CODEGEN)
++ AC_MSG_RESULT($PYGTK_CODEGEN)
++fi
+
+ #########################
+ # Check if build tests
+@@ -278,4 +290,5 @@
+ Tests: $enable_tests
+ Mono tests: $have_nunit
+ gcov: $use_gcov
++ Python: $enable_python
+ ])
diff --git a/dev-libs/libappindicator/libappindicator-12.10.0-r1.ebuild b/dev-libs/libappindicator/libappindicator-12.10.0-r1.ebuild
new file mode 100644
index 000000000000..b3acba689e21
--- /dev/null
+++ b/dev-libs/libappindicator/libappindicator-12.10.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils vala
+
+DESCRIPTION="A library to allow applications to export a menu into the Unity Menu bar"
+HOMEPAGE="http://launchpad.net/libappindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libdbusmenu-0.6.2[gtk3]
+ >=dev-libs/libindicator-12.10.0:3
+ >=x11-libs/gtk+-3.2:3
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # Don't use -Werror
+ sed -i -e 's/ -Werror//' {src,tests}/Makefile.{am,in} || die
+
+ # Disable MONO for now because of http://bugs.gentoo.org/382491
+ sed -i -e '/^MONO_REQUIRED_VERSION/s:=.*:=9999:' configure || die
+ use introspection && vala_src_prepare
+}
+
+src_configure() {
+ # http://bugs.gentoo.org/409133
+ export APPINDICATOR_PYTHON_CFLAGS=' '
+ export APPINDICATOR_PYTHON_LIBS=' '
+
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-gtk=3
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog
+
+ prune_libtool_files
+}
diff --git a/dev-libs/libappindicator/libappindicator-12.10.0-r200.ebuild b/dev-libs/libappindicator/libappindicator-12.10.0-r200.ebuild
new file mode 100644
index 000000000000..8f99794f0222
--- /dev/null
+++ b/dev-libs/libappindicator/libappindicator-12.10.0-r200.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib-minimal python-single-r1 vala
+
+DESCRIPTION="A library to allow applications to export a menu into the Unity Menu bar"
+HOMEPAGE="http://launchpad.net/libappindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.98[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libdbusmenu-0.6.2[gtk,${MULTILIB_USEDEP}]
+ >=dev-libs/libindicator-12.10.0:0[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP},introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ introspection? ( $(vala_depend) )
+"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't use -Werror
+ sed -i -e 's/ -Werror//' {src,tests}/Makefile.{am,in} || die
+
+ epatch "${FILESDIR}"/${P}-conditional-py-bindings.patch
+ eautoreconf
+
+ # Disable MONO for now because of http://bugs.gentoo.org/382491
+ sed -i -e '/^MONO_REQUIRED_VERSION/s:=.*:=9999:' configure || die
+}
+
+multilib_src_configure() {
+ if multilib_is_native_abi; then
+ local -x VALAC VAPIGEN_VAPIDIR PKG_CONFIG_PATH
+ use introspection && vala_src_prepare
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ --with-gtk=2 \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_enable python)
+}
+
+multilib_src_install() {
+ emake -j1 DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog
+
+ prune_libtool_files --modules
+
+ # installed by slot 3 as well
+ rm -r "${D}"usr/share/gtk-doc || die
+}
diff --git a/dev-libs/libappindicator/libappindicator-12.10.0-r300.ebuild b/dev-libs/libappindicator/libappindicator-12.10.0-r300.ebuild
new file mode 100644
index 000000000000..e334366c9572
--- /dev/null
+++ b/dev-libs/libappindicator/libappindicator-12.10.0-r300.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils multilib-minimal vala
+
+DESCRIPTION="A library to allow applications to export a menu into the Unity Menu bar"
+HOMEPAGE="http://launchpad.net/libappindicator"
+SRC_URI="http://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.98[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libdbusmenu-0.6.2[gtk3,${MULTILIB_USEDEP}]
+ >=dev-libs/libindicator-12.10.0:3[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP},introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # Don't use -Werror
+ sed -i -e 's/ -Werror//' {src,tests}/Makefile.{am,in} || die
+
+ epatch "${FILESDIR}"/${P}-conditional-py-bindings.patch
+ eautoreconf
+
+ # Disable MONO for now because of http://bugs.gentoo.org/382491
+ sed -i -e '/^MONO_REQUIRED_VERSION/s:=.*:=9999:' configure || die
+}
+
+multilib_src_configure() {
+ if multilib_is_native_abi; then
+ local -x VALAC VAPIGEN_VAPIDIR PKG_CONFIG_PATH
+ use introspection && vala_src_prepare
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ --with-gtk=3 \
+ $(multilib_native_use_enable introspection)
+}
+
+multilib_src_install() {
+ emake -j1 DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog
+
+ prune_libtool_files
+}
diff --git a/dev-libs/libappindicator/metadata.xml b/dev-libs/libappindicator/metadata.xml
new file mode 100644
index 000000000000..0bf274070abc
--- /dev/null
+++ b/dev-libs/libappindicator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ayatana</herd>
+ <maintainer>
+ <email>ayatana-bugs@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">libappindicator</remote-id>
+ </upstream>
+</pkgmetadata>