summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-11-18 17:57:24 +0100
committerAmy Liffey <amynka@gentoo.org>2018-11-18 17:57:24 +0100
commit30d6fbb0dc72ea75ef9b01c1723ab0b567f99791 (patch)
tree11f3b65c9f6b9927005d560a41a711826aabe71f /dev-libs/libarcus
parentapp-admin/syslog-ng: stable 3.17.2 for ppc64, bug #670974 (diff)
downloadgentoo-30d6fbb0dc72ea75ef9b01c1723ab0b567f99791.tar.gz
gentoo-30d6fbb0dc72ea75ef9b01c1723ab0b567f99791.tar.bz2
gentoo-30d6fbb0dc72ea75ef9b01c1723ab0b567f99791.zip
dev-libs/libarcus: version bump 3.5.1
Bug: https://bugs.gentoo.org/669264 Submitted-by: qwertyqwertyq@protonmail.com Signed-off-by: Amy Liffey <amynka@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libarcus')
-rw-r--r--dev-libs/libarcus/Manifest1
-rw-r--r--dev-libs/libarcus/libarcus-3.5.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libarcus/Manifest b/dev-libs/libarcus/Manifest
index 8d47b3cb406d..96f22701ff6e 100644
--- a/dev-libs/libarcus/Manifest
+++ b/dev-libs/libarcus/Manifest
@@ -1,2 +1,3 @@
DIST libarcus-3.3.0.tar.gz 29695 BLAKE2B a63ca06133cf7db556fe82cc7ea060badd7838d697822d64e09c52aaa81a8509bfa6010037004593da3b1e66dde510767a992524f8e1719e614932b88b9393fe SHA512 a911fb5784ceb835ba2c175ce42cc10544bdd0834e987d8ac1be2517293f00e596f94910d8bf5f37f61e63246ba6e78d28a23bc061809e70b1bb6ad1a21107c9
DIST libarcus-3.4.1.tar.gz 29699 BLAKE2B 73f132ff9d908468f1d67c54b7430ac84c0aebb5dd12282dc894b877a91da3f9822e4db8bf16cb53f313396598d3890be9e06e50737b0a50edfc84543285f251 SHA512 63ed8d8da389641b91ed955624c04ca5488f98d3ef409c4a94ad1962155d6aedd8d61ca0231543cfe4e92ae10beb00001f957eb48f74b0c21447a1bd9b66d85d
+DIST libarcus-3.5.1.tar.gz 28935 BLAKE2B ae850a0923e45446f248fb9944cd795cfa07e05ae4a1c0c91089fd60711603cb1c7b6c3ec81e71496e1a5a2752abb215cbcf725be65a0f8ca92dd0c9d24ed3f1 SHA512 a3cf8599aee83aa080d23849c2c9760e1342fd738db58f4e4bb974a9c3f3dfa34dab1fead6292aa6e27ad9a659fda7b92f031c141039bc3118df8f97cc4b8712
diff --git a/dev-libs/libarcus/libarcus-3.5.1.ebuild b/dev-libs/libarcus/libarcus-3.5.1.ebuild
new file mode 100644
index 000000000000..3714aa3353b2
--- /dev/null
+++ b/dev-libs/libarcus/libarcus-3.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit cmake-utils python-single-r1
+
+MY_PN="libArcus"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libArcus"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-libs/protobuf
+ python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON=$(usex python ON OFF)
+ -DBUILD_EXAMPLES=$(usex examples ON OFF)
+ -DBUILD_STATIC=$(usex static-libs ON OFF)
+ )
+ use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
+ cmake-utils_src_configure
+}