summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-12-15 00:00:29 +0000
committerThomas Deutschmann <whissi@gentoo.org>2018-12-17 00:30:04 +0100
commit757119adababf454e5911000b955a11fcf00079f (patch)
tree340938ac0d1f95e42dfd3e2b32d725dec33286b8 /dev-libs/libbson/libbson-1.13.0.ebuild
parentdev-php/pecl-mongodb: skip failing test (diff)
downloadgentoo-757119adababf454e5911000b955a11fcf00079f.tar.gz
gentoo-757119adababf454e5911000b955a11fcf00079f.tar.bz2
gentoo-757119adababf454e5911000b955a11fcf00079f.zip
dev-libs/libbson: bump to 1.13.0
Closes: https://bugs.gentoo.org/673086 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/libbson/libbson-1.13.0.ebuild')
-rw-r--r--dev-libs/libbson/libbson-1.13.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libbson/libbson-1.13.0.ebuild b/dev-libs/libbson/libbson-1.13.0.ebuild
new file mode 100644
index 000000000000..21e18585ce53
--- /dev/null
+++ b/dev-libs/libbson/libbson-1.13.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Library routines related to building,parsing and iterating BSON documents"
+HOMEPAGE="https://github.com/mongodb/mongo-c-driver/tree/master/src/libbson"
+SRC_URI="https://github.com/mongodb/mongo-c-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="examples static-libs"
+
+DEPEND="dev-python/sphinx"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-uninstall.patch"
+)
+
+S="${WORKDIR}/mongo-c-driver-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BSON=ON
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_MAN_PAGES=ON
+ -DENABLE_MONGOC=OFF
+ -DENABLE_TESTS=OFF
+ -DENABLE_STATIC="$(usex static-libs ON OFF)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use examples; then
+ docinto examples
+ dodoc src/libbson/examples/*.c
+ fi
+
+ cmake-utils_src_install
+}