summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2019-12-15 19:20:20 +0100
committerDaniel Pielmeier <billie@gentoo.org>2019-12-15 19:21:04 +0100
commit2e6417e1a4c01e962c8dc7cb2d5e5e1127330044 (patch)
tree02ff1e6505a5d3c1dbca89e20053d4a289f9ddd1 /dev-libs/libburn/libburn-1.5.2_p1.ebuild
parentsys-kernel/linux-firmware: new snapshot (diff)
downloadgentoo-2e6417e1a4c01e962c8dc7cb2d5e5e1127330044.tar.gz
gentoo-2e6417e1a4c01e962c8dc7cb2d5e5e1127330044.tar.bz2
gentoo-2e6417e1a4c01e962c8dc7cb2d5e5e1127330044.zip
dev-libs/libburn: Version bump libburn-1.5.2_p1.
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'dev-libs/libburn/libburn-1.5.2_p1.ebuild')
-rw-r--r--dev-libs/libburn/libburn-1.5.2_p1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libburn/libburn-1.5.2_p1.ebuild b/dev-libs/libburn/libburn-1.5.2_p1.ebuild
new file mode 100644
index 000000000000..e77f0b1b71a3
--- /dev/null
+++ b/dev-libs/libburn/libburn-1.5.2_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_p1/.pl01}
+
+DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wikis/home"
+SRC_URI="http://files.libburnia-project.org/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug static-libs"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+"
+
+S="${WORKDIR}/${P/_p1}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-ldconfig-at-install \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.txt}
+
+ docinto cdrskin
+ dodoc cdrskin/{*.txt,README}
+ docinto cdrskin/html
+ dodoc cdrskin/cdrskin_eng.html
+
+ find "${D}" -name '*.la' -delete || die
+}