summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-06 10:22:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-06 11:48:50 +0200
commitb980daeece8bde256a99e1dfa303a9d84bb9471e (patch)
tree43bbf90d48045aafa79523a0083d23ae3c7278ab /dev-libs/libbytesize/libbytesize-0.10.ebuild
parentdev-python/pocketlint: Initial commit. (diff)
downloadgentoo-b980daeece8bde256a99e1dfa303a9d84bb9471e.tar.gz
gentoo-b980daeece8bde256a99e1dfa303a9d84bb9471e.tar.bz2
gentoo-b980daeece8bde256a99e1dfa303a9d84bb9471e.zip
dev-libs/libbytesize: Initial commit.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs/libbytesize/libbytesize-0.10.ebuild')
-rw-r--r--dev-libs/libbytesize/libbytesize-0.10.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/libbytesize-0.10.ebuild b/dev-libs/libbytesize/libbytesize-0.10.ebuild
new file mode 100644
index 000000000000..9a089877335e
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-0.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/rhinstaller/libbytesize"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gmp:0=
+ >=dev-libs/libpcre-8.32
+"
+
+DEPEND="
+ ${CDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint
+ dev-python/polib
+ )
+"
+
+RDEPEND="
+ ${CDEPEND}
+"
+
+# https://github.com/rhinstaller/libbytesize/issues/27
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc gtk-doc)
+ )
+ econf "${myeconfargs[@]}"
+}