summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-05 09:30:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-05 09:31:03 +0200
commite1840495847d210fcce0f78e48185475f27400b3 (patch)
treed9a75d9f8b09c93cef4446040ca6016e5bd76a62 /dev-libs/libbytesize/libbytesize-2.1.ebuild
parentnet-mail/courier-imap: Install a monthly cron job for dhparams (diff)
downloadgentoo-e1840495847d210fcce0f78e48185475f27400b3.tar.gz
gentoo-e1840495847d210fcce0f78e48185475f27400b3.tar.bz2
gentoo-e1840495847d210fcce0f78e48185475f27400b3.zip
dev-libs/libbytesize: Bump to version 2.1
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libbytesize/libbytesize-2.1.ebuild')
-rw-r--r--dev-libs/libbytesize/libbytesize-2.1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/libbytesize-2.1.ebuild b/dev-libs/libbytesize/libbytesize-2.1.ebuild
new file mode 100644
index 000000000000..f3c68f3c42fe
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-2.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/storaged-project/libbytesize"
+SRC_URI="https://github.com/storaged-project/libbytesize/releases/download/${PV}/${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc python test tools"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tools? ( python )
+"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:=
+ dev-libs/libpcre2
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md )
+
+RESTRICT="test"
+
+python_do() {
+ if use python; then
+ python_foreach_impl run_in_build_dir "$@"
+ else
+ "$@"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc gtk-doc)
+ $(use_with python python3)
+ $(use_with tools)
+ )
+ local ECONF_SOURCE="${S}"
+ python_do econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ python_do emake
+}
+
+src_test() {
+ python_do emake check
+}
+
+install_helper() {
+ emake DESTDIR="${D}" install
+ use python && python_optimize
+}
+
+src_install() {
+ python_do install_helper
+ einstalldocs
+ find "${ED}" -name "*.la" -type f -delete || die
+}