summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-06 18:59:50 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-06 19:08:31 +0100
commit2d0c8224c6a39cdc708e033854015442a67be10d (patch)
tree9ef167e2bd18db213435f6a19d735c9f85618a2e /dev-libs/libbytesize/libbytesize-2.2.ebuild
parentapp-text/nuspell: Improve integration of tests (diff)
downloadgentoo-2d0c8224c6a39cdc708e033854015442a67be10d.tar.gz
gentoo-2d0c8224c6a39cdc708e033854015442a67be10d.tar.bz2
gentoo-2d0c8224c6a39cdc708e033854015442a67be10d.zip
dev-libs/libbytesize: Bump to version 2.2
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libbytesize/libbytesize-2.2.ebuild')
-rw-r--r--dev-libs/libbytesize/libbytesize-2.2.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/libbytesize-2.2.ebuild b/dev-libs/libbytesize/libbytesize-2.2.ebuild
new file mode 100644
index 000000000000..0d91bc5f9998
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-2.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/storaged-project/libbytesize"
+SRC_URI="https://github.com/storaged-project/libbytesize/releases/download/${PV}/${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc python test tools"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tools? ( python )
+"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:=
+ dev-libs/libpcre2
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md )
+
+RESTRICT="test"
+
+python_do() {
+ if use python; then
+ python_foreach_impl run_in_build_dir "$@"
+ else
+ "$@"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc gtk-doc)
+ $(use_with python python3)
+ $(use_with tools)
+ )
+ local ECONF_SOURCE="${S}"
+ python_do econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ python_do emake
+}
+
+src_test() {
+ python_do emake check
+}
+
+install_helper() {
+ emake DESTDIR="${D}" install
+ use python && python_optimize
+}
+
+src_install() {
+ python_do install_helper
+ einstalldocs
+ find "${ED}" -name "*.la" -type f -delete || die
+}