summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-23 14:44:35 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-23 15:06:01 +0200
commit21c239f3bfb548ecb34effaa32214d454c1275bc (patch)
treea7e16e61a073271773ff2cda1169fbb013e142b3 /dev-libs/libbytesize/libbytesize-2.3.ebuild
parentdev-libs/libbytesize: Removed old (diff)
downloadgentoo-21c239f3bfb548ecb34effaa32214d454c1275bc.tar.gz
gentoo-21c239f3bfb548ecb34effaa32214d454c1275bc.tar.bz2
gentoo-21c239f3bfb548ecb34effaa32214d454c1275bc.zip
dev-libs/libbytesize: Don't build with "-Werror" by default
Closes: https://bugs.gentoo.org/744286 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libbytesize/libbytesize-2.3.ebuild')
-rw-r--r--dev-libs/libbytesize/libbytesize-2.3.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-libs/libbytesize/libbytesize-2.3.ebuild b/dev-libs/libbytesize/libbytesize-2.3.ebuild
index bdb2d302c576..e63686f19435 100644
--- a/dev-libs/libbytesize/libbytesize-2.3.ebuild
+++ b/dev-libs/libbytesize/libbytesize-2.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-r1
+inherit autotools python-r1
DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
HOMEPAGE="https://github.com/storaged-project/libbytesize"
@@ -42,6 +42,10 @@ DOCS=( README.md )
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4-no_Werror.patch"
+)
+
python_do() {
if use python; then
python_foreach_impl run_in_build_dir "$@"
@@ -50,6 +54,11 @@ python_do() {
fi
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_with doc gtk-doc)