summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-07 08:55:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-07 08:55:42 +0200
commit44fb3b7c3e5bb99a64d3a2d182682dcd3abc9438 (patch)
tree59d3a2d03fa6a4d330733f378fe06f339c6d187b /dev-libs/libbytesize
parentmedia-libs/gd: Minor code beautification. (diff)
downloadgentoo-44fb3b7c3e5bb99a64d3a2d182682dcd3abc9438.tar.gz
gentoo-44fb3b7c3e5bb99a64d3a2d182682dcd3abc9438.tar.bz2
gentoo-44fb3b7c3e5bb99a64d3a2d182682dcd3abc9438.zip
dev-libs/libbytesize: Bump to version 0.11
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libbytesize')
-rw-r--r--dev-libs/libbytesize/Manifest1
-rw-r--r--dev-libs/libbytesize/libbytesize-0.11.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/Manifest b/dev-libs/libbytesize/Manifest
index 87670dcaf658..ac531a2417ab 100644
--- a/dev-libs/libbytesize/Manifest
+++ b/dev-libs/libbytesize/Manifest
@@ -1 +1,2 @@
DIST libbytesize-0.10.tar.gz 67461 SHA256 6178bebe3d966ef477c9507a7b8da5c7fb5ff52e792763270286a42e6b892aee SHA512 26dcca781c70b5fdc0c0ef973ce65db2c4ce4520bb413b2e0137e3c8a0ccef0b0b47f46e50e13035fb74c3bd2a16ab8faad8c4fb843f33419a5e5d70dae73587 WHIRLPOOL c91b63e76a368aff4434cc09f546b1ee2265afa95fa6ef6ad25e6ed3554262361342c60ff7fddcc9887b3ddb53c2d5c6890dd28427e35be4af9c12fdc1dc6d53
+DIST libbytesize-0.11.tar.gz 68322 SHA256 3eff9a4b3350420b5e1ecfff523a739049d000b34485e3e1ccf4a4d7685490cb SHA512 3275116a74ead484508da494934062e77d19b50dcd124d7b309137e52a416474099685c39ddc63090d6ed124a667c7fc8c2a7a5844712b33f277703bb52d54ec WHIRLPOOL 717b33b11739747245f74cb6a9b33cbf6cc0e421c5464f253254642e82dfbf55dad26fcf440db3c345dfad7c721c10e0501be409f7b6f8ebcbc6bb0c276687c7
diff --git a/dev-libs/libbytesize/libbytesize-0.11.ebuild b/dev-libs/libbytesize/libbytesize-0.11.ebuild
new file mode 100644
index 000000000000..9a089877335e
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-0.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/rhinstaller/libbytesize"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gmp:0=
+ >=dev-libs/libpcre-8.32
+"
+
+DEPEND="
+ ${CDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint
+ dev-python/polib
+ )
+"
+
+RDEPEND="
+ ${CDEPEND}
+"
+
+# https://github.com/rhinstaller/libbytesize/issues/27
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc gtk-doc)
+ )
+ econf "${myeconfargs[@]}"
+}