summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2018-01-14 13:37:00 +0000
committerIan Whyman <thev00d00@gentoo.org>2018-01-14 13:37:17 +0000
commitbeda18baef91187b4c764e5c946ca3d965c36c6f (patch)
treef51e2e3542d5de2c47c660503c31564035bfbc3f /dev-libs/libcec/files
parentpackage.mask: Mask app-office/odeskteam (diff)
downloadgentoo-beda18baef91187b4c764e5c946ca3d965c36c6f.tar.gz
gentoo-beda18baef91187b4c764e5c946ca3d965c36c6f.tar.bz2
gentoo-beda18baef91187b4c764e5c946ca3d965c36c6f.zip
dev-libs/libcec: Fix build with ncurses[tinfo]
Closes: https://bugs.gentoo.org/615634 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libcec/files')
-rw-r--r--dev-libs/libcec/files/libcec-4.0.2-no-tinfo.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libcec/files/libcec-4.0.2-no-tinfo.patch b/dev-libs/libcec/files/libcec-4.0.2-no-tinfo.patch
new file mode 100644
index 000000000000..673c6f86c972
--- /dev/null
+++ b/dev-libs/libcec/files/libcec-4.0.2-no-tinfo.patch
@@ -0,0 +1,25 @@
+--- libcec-libcec-4.0.2/src/cec-client/CMakeLists.txt
++++ libcec-libcec-4.0.2/src/cec-client/CMakeLists.txt
+@@ -27,8 +27,12 @@ set(cecclient_SOURCES cec-client.cpp)
+ check_library_exists(curses initscr "" HAVE_CURSES_API)
+ if (HAVE_CURSES_API)
+ list(APPEND cecclient_SOURCES curses/CursesControl.cpp)
++
++ # tinfo
++ find_library(HAVE_CURSES_TINFO tinfo)
+ endif()
+
++
+ add_executable(cec-client ${cecclient_SOURCES})
+ set_target_properties(cec-client PROPERTIES VERSION ${LIBCEC_VERSION_MAJOR}.${LIBCEC_VERSION_MINOR}.${LIBCEC_VERSION_PATCH})
+ target_link_libraries(cec-client ${p8-platform_LIBRARIES})
+@@ -44,6 +48,9 @@ if (NOT WIN32)
+ # curses
+ if (HAVE_CURSES_API)
+ target_link_libraries(cec-client curses)
++ if (HAVE_CURSES_TINFO)
++ target_link_libraries(cec-client tinfo)
++ endif()
+ endif()
+
+ # rt