summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libcec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libcec')
-rw-r--r--dev-libs/libcec/Manifest3
-rw-r--r--dev-libs/libcec/files/libcec-1.8.1-eintr-retry.patch30
-rw-r--r--dev-libs/libcec/libcec-2.1.3.ebuild42
-rw-r--r--dev-libs/libcec/libcec-2.1.4.ebuild43
-rw-r--r--dev-libs/libcec/libcec-2.2.0.ebuild46
-rw-r--r--dev-libs/libcec/metadata.xml17
6 files changed, 181 insertions, 0 deletions
diff --git a/dev-libs/libcec/Manifest b/dev-libs/libcec/Manifest
new file mode 100644
index 000000000000..de40dfd12d37
--- /dev/null
+++ b/dev-libs/libcec/Manifest
@@ -0,0 +1,3 @@
+DIST libcec-2.1.3.tar.gz 1087121 SHA256 2aa88451b528184b02077ee8c6cd10e2f89121a6a05b1b35b4b792b03108a9d1 SHA512 79ddab6e1572030d860fa2ba43db7ed4ea6eb7914d3b9936c9de622f1328c1795ae3076d0c6abde193fa610a7916439f8cebdcf3bf22b59f6546ac591b4e5956 WHIRLPOOL e8400d037dee3bdb007b5e731aa794ac5dcf94ad1d4c1d1cbe39c059c77f2b2785288f3fbc987fa64eafb1dc0e2a96a9575a3cb5740edf25088c586a1b628e3d
+DIST libcec-2.1.4.tar.gz 1093796 SHA256 79bef5232a5c9ab987ca3a2d4bfcaeb80480fd26f502dc1a996fe845d90fe147 SHA512 e2107b2003e003de8efea4b46a7776516652a2b27a0e0983a763324b3ac1ed2995cb0adb76e2f450bea72a1a0bdecfc5b3408fa702c74189204d694f5e9d2d8a WHIRLPOOL 4b8120755cf08dbc7ae8f2a5314f6c4e0c2ddc059b138ab594a26f7ac931cb34536a5bb2894a65902f1ba093007c1b08abeaf4306edef95059af8c85edad3e99
+DIST libcec-2.2.0.tar.gz 1099150 SHA256 fd4f47a18d6e0f4b9e6f5831280207ee2b2a5fc2741ae32ae09ad12a8aa52917 SHA512 7932a45e581e207aa651e9fe72450fda52b0441fb48e40e971a530f9d5d26b87e6446322393750d85bae223519dc2a73613352a3fe42939eff2c5f8863a09cd7 WHIRLPOOL ff8581c21e280fda6333aec840cbc08fd8d23ffa795fe173076d1863c0b8fdc86fb7838c2035940dac61362ec1c74054e6e450fff7ba5426ff57a2016c6eab83
diff --git a/dev-libs/libcec/files/libcec-1.8.1-eintr-retry.patch b/dev-libs/libcec/files/libcec-1.8.1-eintr-retry.patch
new file mode 100644
index 000000000000..7b472d0aaf6b
--- /dev/null
+++ b/dev-libs/libcec/files/libcec-1.8.1-eintr-retry.patch
@@ -0,0 +1,30 @@
+From 8f6c59829bb84edc66ce0edb0a4d5b7335a941c6 Mon Sep 17 00:00:00 2001
+From: Josef Fruehwirth <fruehwirth@gmail.com>
+Date: Sat, 18 Aug 2012 14:07:04 +0200
+Subject: [PATCH] Retry m_port->Read(..) if an EINTR errror occurs instead of
+ closing the connection.
+
+---
+ src/lib/adapter/Pulse-Eight/USBCECAdapterCommunication.cpp | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/lib/adapter/Pulse-Eight/USBCECAdapterCommunication.cpp b/src/lib/adapter/Pulse-Eight/USBCECAdapterCommunication.cpp
+index 70e45ac..3fc05eb 100644
+--- a/src/lib/adapter/Pulse-Eight/USBCECAdapterCommunication.cpp
++++ b/src/lib/adapter/Pulse-Eight/USBCECAdapterCommunication.cpp
+@@ -393,7 +393,11 @@ bool CUSBCECAdapterCommunication::ReadFromDevice(uint32_t iTimeout, size_t iSize
+ if (!IsOpen())
+ return false;
+
+- iBytesRead = m_port->Read(buff, sizeof(uint8_t) * iSize, iTimeout);
++ do {
++ /* retry Read() if it was interrupted */
++ iBytesRead = m_port->Read(buff, sizeof(uint8_t) * iSize, iTimeout);
++ } while(m_port->GetErrorNumber() == EINTR);
++
+
+ if (m_port->GetErrorNumber())
+ {
+--
+1.7.10
+
diff --git a/dev-libs/libcec/libcec-2.1.3.ebuild b/dev-libs/libcec/libcec-2.1.3.ebuild
new file mode 100644
index 000000000000..24197aca8487
--- /dev/null
+++ b/dev-libs/libcec/libcec-2.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils linux-info vcs-snapshot
+
+DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
+HOMEPAGE="http://libcec.pulse-eight.com"
+SRC_URI="http://github.com/Pulse-Eight/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug static-libs"
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ dev-libs/lockdev
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~USB_ACM"
+
+src_prepare() {
+ sed -i '/^CXXFLAGS/s:-fPIC::' configure.ac || die
+ sed -i '/^CXXFLAGS/s:-Werror::' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ $(use_enable debug) \
+ --enable-optimisation \
+ --disable-rpi \
+ --disable-cubox
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/dev-libs/libcec/libcec-2.1.4.ebuild b/dev-libs/libcec/libcec-2.1.4.ebuild
new file mode 100644
index 000000000000..559be7c88a2b
--- /dev/null
+++ b/dev-libs/libcec/libcec-2.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils linux-info
+
+DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
+HOMEPAGE="http://libcec.pulse-eight.com"
+SRC_URI="http://github.com/Pulse-Eight/${PN}/archive/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="virtual/udev
+ dev-libs/lockdev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~USB_ACM"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ sed -i '/^CXXFLAGS/s:-fPIC::' configure.ac || die
+ sed -i '/^CXXFLAGS/s:-Werror::' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ $(use_enable debug) \
+ --enable-optimisation \
+ --disable-rpi \
+ --disable-cubox
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/dev-libs/libcec/libcec-2.2.0.ebuild b/dev-libs/libcec/libcec-2.2.0.ebuild
new file mode 100644
index 000000000000..ee8dcfc7983f
--- /dev/null
+++ b/dev-libs/libcec/libcec-2.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils linux-info
+
+DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
+HOMEPAGE="http://libcec.pulse-eight.com"
+SRC_URI="http://github.com/Pulse-Eight/${PN}/archive/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="cubox debug exynos raspberry-pi static-libs xrandr"
+
+RDEPEND="virtual/udev
+ dev-libs/lockdev
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~USB_ACM"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ sed -i '/^CXXFLAGS/s:-fPIC::' configure.ac || die
+ sed -i '/^CXXFLAGS/s:-Werror::' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable cubox ) \
+ $(use_enable debug) \
+ $(use_enable exynos) \
+ $(use_enable raspberry-pi rpi) \
+ $(use_enable static-libs static) \
+ --enable-optimisation
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/dev-libs/libcec/metadata.xml b/dev-libs/libcec/metadata.xml
new file mode 100644
index 000000000000..cbd0140d04d2
--- /dev/null
+++ b/dev-libs/libcec/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>thev00d00@gentoo.org</email>
+ <name>Ian Whyman</name>
+ </maintainer>
+ <use>
+ <flag name="cubox">Enable support for enable support for the TDA995x</flag>
+ <flag name="exynos">Enable support for Exynos chipsets</flag>
+ <flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
+ <flag name="xrandr">Enable detection of active HDMI using xrandr extensions</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Pulse-Eight/libcec</remote-id>
+ </upstream>
+</pkgmetadata>