summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-27 00:49:25 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-27 00:51:37 -0400
commit6a7affbd5b76ff483e6c8de31c090dab1509a239 (patch)
treeb27001c3c3d36db96ffbb34cb32079414f2afdd8 /dev-libs/libcec
parentdev-libs/libplatform: minor style cleanup (diff)
downloadgentoo-6a7affbd5b76ff483e6c8de31c090dab1509a239.tar.gz
gentoo-6a7affbd5b76ff483e6c8de31c090dab1509a239.tar.bz2
gentoo-6a7affbd5b76ff483e6c8de31c090dab1509a239.zip
dev-libs/libcec: fix python libdir install #577612
Diffstat (limited to 'dev-libs/libcec')
-rw-r--r--dev-libs/libcec/libcec-3.0.1.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-libs/libcec/libcec-3.0.1.ebuild b/dev-libs/libcec/libcec-3.0.1.ebuild
index 0c343ba05056..8a535752387e 100644
--- a/dev-libs/libcec/libcec-3.0.1.ebuild
+++ b/dev-libs/libcec/libcec-3.0.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI="5"
+
PYTHON_COMPAT=( python2_7 python3_4 )
inherit cmake-utils eutils linux-info python-single-r1
@@ -10,10 +11,10 @@ inherit cmake-utils eutils linux-info python-single-r1
DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
HOMEPAGE="http://libcec.pulse-eight.com"
SRC_URI="https://github.com/Pulse-Eight/${PN}/archive/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~arm ~amd64 ~x86"
-
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="cubox exynos python raspberry-pi +xrandr"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -39,6 +40,11 @@ pkg_setup() {
}
src_prepare() {
+ # Do not hardcode the python libpath #577612
+ sed -i \
+ -e '/DESTINATION/s:lib/python${PYTHON_VERSION}/dist-packages:${PYTHON_SITEDIR}:' \
+ src/libcec/cmake/CheckPlatformSupport.cmake || die
+
cmake-utils_src_prepare
use python || comment_add_subdirectory "src/pyCecClient"
}
@@ -46,9 +52,10 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
$(cmake-utils_useno python SKIP_PYTHON_WRAPPER)
- $(cmake-utils_use_has exynos EXYNOS_API) \
+ $(cmake-utils_use_has exynos EXYNOS_API)
$(cmake-utils_use_has cubox TDA955X_API)
$(cmake-utils_use_has raspberry-pi RPI_API)
)
+ use python && mycmakeargs+=( -DPYTHON_SITEDIR="$(python_get_sitedir)" )
cmake-utils_src_configure
}