summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-18 23:04:35 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-18 23:07:39 -0400
commit80e6ab4cba3ec14990eb9267c1905138509478af (patch)
tree7681cc7beb5749197d460e06e27c5b8758aa981a /dev-libs/libebml/libebml-1.3.4.ebuild
parentwww-client/chromium: beta channel bump (53.0.2785.70) (diff)
downloadgentoo-80e6ab4cba3ec14990eb9267c1905138509478af.tar.gz
gentoo-80e6ab4cba3ec14990eb9267c1905138509478af.tar.bz2
gentoo-80e6ab4cba3ec14990eb9267c1905138509478af.zip
dev-libs/libebml: version bump to 1.3.4
Diffstat (limited to 'dev-libs/libebml/libebml-1.3.4.ebuild')
-rw-r--r--dev-libs/libebml/libebml-1.3.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libebml/libebml-1.3.4.ebuild b/dev-libs/libebml/libebml-1.3.4.ebuild
new file mode 100644
index 000000000000..72f0399ab379
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.3.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="http://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
+SRC_URI="http://dl.matroska.org/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug static-libs"
+
+src_prepare() {
+ default
+ sed -i '/^AM_CXXFLAGS += -g/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}