summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-08-19 14:32:59 +0000
committerYixun Lan <dlan@gentoo.org>2015-08-19 14:53:31 +0000
commitd19a938f6ed0aaa280f4269647f1607735a01fac (patch)
tree3f4f402e5fc64e4eed22421dcba382ffc1fab5fa /dev-libs/libev/libev-4.20.ebuild
parentOld. (diff)
downloadgentoo-d19a938f6ed0aaa280f4269647f1607735a01fac.tar.gz
gentoo-d19a938f6ed0aaa280f4269647f1607735a01fac.tar.bz2
gentoo-d19a938f6ed0aaa280f4269647f1607735a01fac.zip
dev-libs/libev: version bump 4.20
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-libs/libev/libev-4.20.ebuild')
-rw-r--r--dev-libs/libev/libev-4.20.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libev/libev-4.20.ebuild b/dev-libs/libev/libev-4.20.ebuild
new file mode 100644
index 000000000000..fdf615188227
--- /dev/null
+++ b/dev-libs/libev/libev-4.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="elibc_glibc static-libs"
+
+# Bug #283558
+DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( Changes README )
+
+src_prepare() {
+ sed -i -e "/^include_HEADERS/s/ event.h//" Makefile.am || die
+
+ # bug #411847
+ epatch "${FILESDIR}/${PN}-pc.patch"
+
+ epatch_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-maintainer-mode \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files
+ einstalldocs
+}