summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-12-18 19:00:30 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-12-18 19:15:09 +0100
commit21f375df742472e4e4fa17f58de3ba16a1aaa813 (patch)
tree025b7e1f142727fc0a5534a35487a10e95b32748 /dev-libs/libfastjson/libfastjson-0.99.8.ebuild
parentapp-i18n/man-pages-de: Remove old (diff)
downloadgentoo-21f375df742472e4e4fa17f58de3ba16a1aaa813.tar.gz
gentoo-21f375df742472e4e4fa17f58de3ba16a1aaa813.tar.bz2
gentoo-21f375df742472e4e4fa17f58de3ba16a1aaa813.zip
dev-libs/libfastjson: Bump to v0.99.8
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libfastjson/libfastjson-0.99.8.ebuild')
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libfastjson/libfastjson-0.99.8.ebuild b/dev-libs/libfastjson/libfastjson-0.99.8.ebuild
new file mode 100644
index 000000000000..684987488e61
--- /dev/null
+++ b/dev-libs/libfastjson/libfastjson-0.99.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fork of the json-c library, which is optimized for liblognorm processing"
+HOMEPAGE="http://www.rsyslog.com/tag/libfastjson/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0/4.2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-devel/autoconf-archive-2015.02.04"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ $(use_enable static-libs static)
+ --disable-rdrand
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog )
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}