summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-02-23 10:14:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-02-23 10:15:07 +0100
commita4b478e87a5f5c43d6169922bba1b31827c739b3 (patch)
tree113e513b045f247ce30283b9da5a55ab9f58f3c5 /dev-libs/libfilezilla/libfilezilla-0.4.0.1.ebuild
parentsci-libs/mathgl: Version Bump (diff)
downloadgentoo-a4b478e87a5f5c43d6169922bba1b31827c739b3.tar.gz
gentoo-a4b478e87a5f5c43d6169922bba1b31827c739b3.tar.bz2
gentoo-a4b478e87a5f5c43d6169922bba1b31827c739b3.zip
dev-libs/libfilezilla: Bump to version 0.4.0.1
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libfilezilla/libfilezilla-0.4.0.1.ebuild')
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.4.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/libfilezilla-0.4.0.1.ebuild b/dev-libs/libfilezilla/libfilezilla-0.4.0.1.ebuild
new file mode 100644
index 000000000000..2139f8e583c9
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.4.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="mirror://sourceforge/filezilla/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}