summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-08-26 11:36:58 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-26 11:38:54 -0400
commit8d08a00e7d1df3a006ae12d0512ff4948569d427 (patch)
tree60f1a93eb202ad77eb49a121c105439a91533fc6 /dev-libs/libfmt
parentmedia-libs/x265: bump to 3.1.2 (diff)
downloadgentoo-8d08a00e7d1df3a006ae12d0512ff4948569d427.tar.gz
gentoo-8d08a00e7d1df3a006ae12d0512ff4948569d427.tar.bz2
gentoo-8d08a00e7d1df3a006ae12d0512ff4948569d427.zip
dev-libs/libfmt: 6.0.0 version bump
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libfmt')
-rw-r--r--dev-libs/libfmt/Manifest1
-rw-r--r--dev-libs/libfmt/libfmt-6.0.0.ebuild35
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild6
3 files changed, 39 insertions, 3 deletions
diff --git a/dev-libs/libfmt/Manifest b/dev-libs/libfmt/Manifest
index 4c249a97e3c2..fd3dd290d9d2 100644
--- a/dev-libs/libfmt/Manifest
+++ b/dev-libs/libfmt/Manifest
@@ -3,3 +3,4 @@ DIST libfmt-5.1.0.tar.gz 641502 BLAKE2B 8507e875a78de2e89b7fe2c1c049691bfef6e0a7
DIST libfmt-5.2.0.tar.gz 648061 BLAKE2B a2ffe84277097f3cd5bfa163fa12e352349ab8239ab00f071cc0236bdea0c7c15b3c04f40036006fbe6ed231ff19d53abcba7c5dec709e5ac418ad41cc489d4e SHA512 75d53e6d8087288607f75fb891bb8812c7b9fe65e5ab7a20cdffeb5e56bd1f48e0de24c8cf1c2dd603fe3ed76f9fa067804ec5d3560f177db8f0a747c36f9d1c
DIST libfmt-5.2.1.tar.gz 648668 BLAKE2B 516522d4e75e7ccdf95a43bfe1b5f95b8ce8ef0174d6b82d6b7be9985f084228a69e70ecba7f57788d536501699b584cb4eb51d7894b416ea857727b776b3823 SHA512 2b63a741df4df9c3cbf04098c6548bb3d0f9836fe912325542298df57c888f43e72159469fb87685b423694e43e4418545377d5ee6393f2709955be2c13780a8
DIST libfmt-5.3.0.tar.gz 662493 BLAKE2B 462c54c227132b2398977ff575f74e63e973825968b106e09cb0f3da859f1d851a6dd1799c05e3ae6adff2ac972f4af259c42fdf8429346b2830134571c31480 SHA512 9ef0f3d328681253c1e1776576d54d67dec49c19fd7fc422ae63c3610b01a3f05f6e83cdf5e913dfd09bac42e52fe35c38ebe1ea91f4207d226a32aaf69eb4a8
+DIST libfmt-6.0.0.tar.gz 708425 BLAKE2B c04fb7f701e98442848a36489b09eca3dd64f736f668f04173db3afe77da6d933f5f13a2fe38489a5880fa1e4d8549dd34acc9fa37fbb0d6cdee3b6598610726 SHA512 7deb5bd843ae6b9d4b58dca9c68c1cfe7b55a41040f358247f5309655188d1ae194ff414437c068f74367f078faa214b5883e8c9e634c7623dcda50850e24766
diff --git a/dev-libs/libfmt/libfmt-6.0.0.ebuild b/dev-libs/libfmt/libfmt-6.0.0.ebuild
new file mode 100644
index 000000000000..9bb4ee093042
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-6.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib eapi7-ver
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="MIT"
+IUSE="test"
+SLOT="0/$(ver_cut 1)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
index 932e58c0ce52..9bb4ee093042 100644
--- a/dev-libs/libfmt/libfmt-9999.ebuild
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ inherit cmake-multilib eapi7-ver
DESCRIPTION="Small, safe and fast formatting library"
HOMEPAGE="https://github.com/fmtlib/fmt"
-LICENSE="BSD-2"
+LICENSE="MIT"
IUSE="test"
SLOT="0/$(ver_cut 1)"
@@ -17,7 +17,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
S="${WORKDIR}/fmt-${PV}"
fi