summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-09-21 17:42:28 -0400
committerCraig Andrews <candrews@gentoo.org>2018-09-21 17:43:39 -0400
commitc641e26693b773ce21c518210c1d4a1cee1bd242 (patch)
tree97674dc319efc912816b322f9ca2df039fadff4c /dev-libs/libfmt
parentx11-misc/xdotool-3.20160805.1: added ~ppc64, bug 666621 (diff)
downloadgentoo-c641e26693b773ce21c518210c1d4a1cee1bd242.tar.gz
gentoo-c641e26693b773ce21c518210c1d4a1cee1bd242.tar.bz2
gentoo-c641e26693b773ce21c518210c1d4a1cee1bd242.zip
dev-libs/libfmt: 5.2.1 versiom bump
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-libs/libfmt')
-rw-r--r--dev-libs/libfmt/Manifest1
-rw-r--r--dev-libs/libfmt/libfmt-5.2.1.ebuild35
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild6
3 files changed, 39 insertions, 3 deletions
diff --git a/dev-libs/libfmt/Manifest b/dev-libs/libfmt/Manifest
index c7f28d958e30..962ec8c3dbe2 100644
--- a/dev-libs/libfmt/Manifest
+++ b/dev-libs/libfmt/Manifest
@@ -1,3 +1,4 @@
DIST libfmt-4.1.0.tar.gz 620863 BLAKE2B ff3a7db5a1eed3a6fc936be16caf2dd153d9452df16c07d6e0dc718bcfb9f51f52146498cb3f49591f1ad96d36a9561de2a78426d3bb8a0907b772e8be5a6f7f SHA512 8daaa4a61bfe63345a12df0a9bca0b1cd6a162d0f4e97d2d2978ae19a1a1357ec4d4cce948ce726cdbe9403e51ad995950a2a99de28f9b9085c02ce845540b22
DIST libfmt-5.1.0.tar.gz 641502 BLAKE2B 8507e875a78de2e89b7fe2c1c049691bfef6e0a7375ef7958e2191bcc4c60972b54b6ebc213d1465826af8322d8f90b217c1c7e176b29351c733184ff95cca40 SHA512 b759a718353254fa8cd981e483bf01a45af0fc76901216404ace5e47f5d3edf43d42422184e5413c221e49832322fdf60d1860e8ec87349c674511064b31e5d6
DIST libfmt-5.2.0.tar.gz 648061 BLAKE2B a2ffe84277097f3cd5bfa163fa12e352349ab8239ab00f071cc0236bdea0c7c15b3c04f40036006fbe6ed231ff19d53abcba7c5dec709e5ac418ad41cc489d4e SHA512 75d53e6d8087288607f75fb891bb8812c7b9fe65e5ab7a20cdffeb5e56bd1f48e0de24c8cf1c2dd603fe3ed76f9fa067804ec5d3560f177db8f0a747c36f9d1c
+DIST libfmt-5.2.1.tar.gz 648668 BLAKE2B 516522d4e75e7ccdf95a43bfe1b5f95b8ce8ef0174d6b82d6b7be9985f084228a69e70ecba7f57788d536501699b584cb4eb51d7894b416ea857727b776b3823 SHA512 2b63a741df4df9c3cbf04098c6548bb3d0f9836fe912325542298df57c888f43e72159469fb87685b423694e43e4418545377d5ee6393f2709955be2c13780a8
diff --git a/dev-libs/libfmt/libfmt-5.2.1.ebuild b/dev-libs/libfmt/libfmt-5.2.1.ebuild
new file mode 100644
index 000000000000..932e58c0ce52
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-5.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib eapi7-ver
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="BSD-2"
+IUSE="test"
+SLOT="0/$(ver_cut 1)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
index 51fea82ad48f..932e58c0ce52 100644
--- a/dev-libs/libfmt/libfmt-9999.ebuild
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-multilib versionator
+inherit cmake-multilib eapi7-ver
DESCRIPTION="Small, safe and fast formatting library"
HOMEPAGE="https://github.com/fmtlib/fmt"
LICENSE="BSD-2"
IUSE="test"
-SLOT="0/$(get_major_version)"
+SLOT="0/$(ver_cut 1)"
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"