summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-22 14:04:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-22 14:47:32 +0200
commit6378abeb28b9dfafc4b73d9db3d753d7b8a051a3 (patch)
tree78677b0917d2155422e2acf7fd6084d0f3ecbee5 /dev-libs/libgit2
parentnet-misc/anydesk: bump to v5.0.0 (diff)
downloadgentoo-6378abeb28b9dfafc4b73d9db3d753d7b8a051a3.tar.gz
gentoo-6378abeb28b9dfafc4b73d9db3d753d7b8a051a3.tar.bz2
gentoo-6378abeb28b9dfafc4b73d9db3d753d7b8a051a3.zip
dev-libs/libgit2: Bump to 0.28.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/Manifest1
-rw-r--r--dev-libs/libgit2/libgit2-0.28.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index 855dacd8f7e0..ddd2ffeedc5e 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1,3 +1,4 @@
DIST libgit2-0.26.8.tar.gz 4742478 BLAKE2B 31326987961ed42740f6c0ddce6a80c278175899a62cabd65ce9eef60854553e6a91fd9947ca23945104d4e1b46f9ab0bb1a1a793d8dd87bed792528e5c32839 SHA512 efb9229b2882ac36910d75778d7431bec40f3529f2ad2dd6a950d5580ceb0d4dd798242a422ea6cbb880f515df4dfbb7055a65dd5a8106696d3d458851fca56e
DIST libgit2-0.27.8.tar.gz 4783928 BLAKE2B 0f0f79a43de3e869d593dafc1b506ee0894143d2daedf2fe56683ad8f2edfd7d87bab784354b9fb1796fa8e08a36b9de88af65c7621a90d537cb585c89118197 SHA512 53ab69a0687afd315029fdbe0ce8192b7e88f7f1ff6bc9c4875718e638cecd64755a9942ad605e6c388c58c6b892b351d54c5405de8e0d5ba90406055a25ffaa
DIST libgit2-0.28.1.tar.gz 4987204 BLAKE2B bb4f32b0b78a9faed3e5204f40cbda15d032719dfd581948cf175bc17a30356f97f20545e1f64ff6f3cd1dc4ff483af99edb29d7a10c56349ce74976c186886b SHA512 5a1bc5c6af6ad25cb8b2c446e75a774d2a615d4999ec3223d681c7b120d83e7cecd94f1ca549bac0802f5324e27e73cc5a6483ad410636c2f06f098b30b1b647
+DIST libgit2-0.28.2.tar.gz 4987586 BLAKE2B cf791adb173050b4b153062ff5fdc923289462677ce34af1077d228a95c4d9d7e9b836aee44dc79f079f42c910c4b4548241ec7ff16665ce49e319ccd38d4c7a SHA512 0879c162e2e1dc00eadfbda22cd1f9d3a95b4ec2b653c108983f37c2f695140882de4d50d7cbc04ced247125a4e9fe6df16130e1267891aecdb2411d920db5c6
diff --git a/dev-libs/libgit2/libgit2-0.28.2.ebuild b/dev-libs/libgit2/libgit2-0.28.2.ebuild
new file mode 100644
index 000000000000..89a49f8ac99d
--- /dev/null
+++ b/dev-libs/libgit2/libgit2-0.28.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit cmake-utils python-any-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.github.com/"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/28"
+IUSE="examples gssapi libressl +ssh test +threads trace"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib
+ net-libs/http-parser:=
+ gssapi? ( virtual/krb5 )
+ ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${P/_/-}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+ -DBUILD_CLAR=$(usex test)
+ -DENABLE_TRACE=$(usex trace)
+ -DUSE_GSSAPI=$(usex gssapi)
+ -DUSE_SSH=$(usex ssh)
+ -DTHREADSAFE=$(usex threads)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ # repo::iterator::fs_preserves_error fails if run as root
+ # since root can still access dirs with 0000 perms
+ ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+ else
+ local TEST_VERBOSE=1
+ cmake-utils_src_test -R offline
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc docs/*.{md,txt}
+
+ if use examples ; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}