summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-10-03 10:30:19 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-10-03 10:30:19 -0400
commit4c5b04436e05c8dfe7e4ea8107a08670f32d746f (patch)
tree113c4f85ba0d76d1ecdc6323990419ded690d4b6 /dev-libs/libgpiod
parentnet-proxy/torsocks: version bump to 2.3.0, bug #680502 (diff)
downloadgentoo-4c5b04436e05c8dfe7e4ea8107a08670f32d746f.tar.gz
gentoo-4c5b04436e05c8dfe7e4ea8107a08670f32d746f.tar.bz2
gentoo-4c5b04436e05c8dfe7e4ea8107a08670f32d746f.zip
dev-libs/libgpiod: version bump to 1.4.1, bug #671370
Author: gabemarcano@yahoo.com Closes: https://bugs.gentoo.org/671370 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-libs/libgpiod')
-rw-r--r--dev-libs/libgpiod/Manifest1
-rw-r--r--dev-libs/libgpiod/libgpiod-1.4.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/Manifest b/dev-libs/libgpiod/Manifest
index 24dedcf03304..96b415fe2406 100644
--- a/dev-libs/libgpiod/Manifest
+++ b/dev-libs/libgpiod/Manifest
@@ -1 +1,2 @@
DIST libgpiod-1.1.1.tar.xz 302672 BLAKE2B 71c624f923118b7c50970beb737f2c813d1470a34f95798f9ce821211e16f15e2a3fd42d0054e25529ddc9846725c0935d915784f22d2509b844a0bac61b66b6 SHA512 a1d902ce8e1c94d5550ade2fb4889ebe28b86523505b92ab907f58c8e6903eaf07ce16278126989462956b879f591b42ddd50fbc4537c1b5af459f23a4dfc12f
+DIST libgpiod-1.4.1.tar.xz 314936 BLAKE2B 8949c4a96f69a83a479f5951e6f1eb8fee56db700e72320131c365a5d736a48700fb42b7ecc2b676cec54887eaa650075f45ec1f0b803de914958cefd3863db8 SHA512 2a9c58a46fb3c2e2dd15cc4ba52f589b44e5ae4547226eeb68a8e5bea6292d38aaf0889cc639e0979e12e129bb944bb42d9258f10292f59d074660e7c2d56d04
diff --git a/dev-libs/libgpiod/libgpiod-1.4.1.ebuild b/dev-libs/libgpiod/libgpiod-1.4.1.ebuild
new file mode 100644
index 000000000000..50141fbb2619
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib multilib-minimal
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static-libs +tools cxx python test"
+
+# --enable-tests enable libgpiod tests [default=no]
+# --enable-bindings-cxx enable C++ bindings [default=no]
+# --enable-bindings-python
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable tools)
+ $(use_enable cxx bindings-cxx)
+ $(use_enable test tests)
+ $(multilib_native_use_enable python bindings-python)
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ --disable-tools
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+}