summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2016-08-24 02:00:56 +0200
committerThomas Deutschmann <whissi@gentoo.org>2016-08-24 02:57:18 +0200
commit6418fc6dfc6c700410c4877e30857275cea36f8e (patch)
treeb04f9c024d139c2a7076523ea332912a7dba7120 /dev-libs/liblognorm
parentdev-libs/libee: Dropping old versions (diff)
downloadgentoo-6418fc6dfc6c700410c4877e30857275cea36f8e.tar.gz
gentoo-6418fc6dfc6c700410c4877e30857275cea36f8e.tar.bz2
gentoo-6418fc6dfc6c700410c4877e30857275cea36f8e.zip
dev-libs/liblognorm: Bumped to v2.0.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/liblognorm')
-rw-r--r--dev-libs/liblognorm/Manifest1
-rw-r--r--dev-libs/liblognorm/liblognorm-2.0.1.ebuild76
-rw-r--r--dev-libs/liblognorm/metadata.xml3
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/liblognorm/Manifest b/dev-libs/liblognorm/Manifest
index decd9e620798..2b4afd08f47c 100644
--- a/dev-libs/liblognorm/Manifest
+++ b/dev-libs/liblognorm/Manifest
@@ -1,3 +1,4 @@
DIST liblognorm-1.1.0.tar.gz 499355 SHA256 2ddff2ee893c9268e19868f19dc4d8037e3d266c0d001436c33c9429fcbb3030 SHA512 f694d47c8e60871f0f3ce1fe8092b2596850beea618760c289d9cec6068fb8e8e260f4abb3faf20b931864d91ed18f640c65235fd693f6c67ce232fa11006107 WHIRLPOOL b03347d89e86d858d98a2237b6319f1646c995b5a725b486a9288de9a1cfc243b826c822a22f9e5a2a6f3c13c68a2e408ee8d5a68f2c361aeb40bc1b7d8af644
DIST liblognorm-1.1.2.tar.gz 547224 SHA256 935a112fb5310877aaa5046ac8bd2ec7d0e9fed03e2fffccb84b6f93b92a536c SHA512 d0dc206ac2f34174ec1a7e05ae4f84520ae67f49b5540bf9b957378418d6e32384fddd40aaa26dfbdec868a6e7d7a0b677af5201dcbf4f0d4b177934a260ff00 WHIRLPOOL 616fb1b951139576579389141253651b79dd215e742b14b0add81341c2cbeed5411544cf3c92221b4d3f4b459e51d55e59dd789b2cc3ad6fe19afb61ec02d0b6
DIST liblognorm-1.1.3.tar.gz 553372 SHA256 8e370460a152057abc577d59acbe60b7846312897e56f8f9d3e74edf9c621951 SHA512 09c6ab434fcdd788df84341aaf426c51385a8f3cc9960f07b77e369c22b3a1b8d890ba8d4d0507928b235d2667ed7f7a2c935eed8214d698117c8cfecba75d5f WHIRLPOOL 00d86afa82a12145de8165141f44af9913826ddffe0515d4655103f89bb69285cd8ce88fdec31af23214e599b7ac7f572c29d0a829ab0e07f63f45860c936aa7
+DIST liblognorm-2.0.1.tar.gz 657390 SHA256 6a7fda0da2791a87c808fbfde1af20e6463e3ff73496aae7756e3440f3bc5b75 SHA512 557ba4180d764c04edabe6292a44f5340c5b1f7ac2390a4068711be4ad6da7429e651bc2230d6ff9cc6c58cd6a6c59149f20083de8cf4d8239d95f86db39565f WHIRLPOOL ae89d7f34b673f14103574966e72b508d69a00e7f8d13eb5e9665c83303606da729001d7bb0712f96de8c4df63b3c75df90f52ec937b793a503d0062912acd6a
diff --git a/dev-libs/liblognorm/liblognorm-2.0.1.ebuild b/dev-libs/liblognorm/liblognorm-2.0.1.ebuild
new file mode 100644
index 000000000000..10f33676e1c1
--- /dev/null
+++ b/dev-libs/liblognorm/liblognorm-2.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fast samples-based log normalization library"
+HOMEPAGE="http://www.liblognorm.com"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="
+ git://github.com/rsyslog/${PN}.git
+ https://github.com/rsyslog/${PN}.git
+ "
+
+ inherit git-r3
+else
+ SRC_URI="http://www.liblognorm.com/files/download/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-linux"
+fi
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0/5.0.0"
+IUSE="debug doc static-libs test"
+
+RDEPEND="
+ >=dev-libs/libestr-0.1.3
+ >=dev-libs/libfastjson-0.99.2:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/autoconf-archive-2015.02.04
+ virtual/pkgconfig
+ doc? ( >=dev-python/sphinx-1.2.2 )
+"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # regexp disabled due to https://github.com/rsyslog/liblognorm/issues/143
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ --disable-Werror
+ $(use_enable doc docs)
+ $(use_enable test testbench)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ --disable-regexp
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # When adding new tests via patches we have to make them executable
+ einfo "Adjusting permissions of test scripts ..."
+ find "${S}"/tests -type f -name '*.sh' \! -perm -111 -exec chmod a+x '{}' \; || \
+ die "Failed to adjust test scripts permission"
+
+ emake --jobs 1 check
+}
+
+src_install() {
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}
diff --git a/dev-libs/liblognorm/metadata.xml b/dev-libs/liblognorm/metadata.xml
index 7d460c3f26d3..b924356c3cf4 100644
--- a/dev-libs/liblognorm/metadata.xml
+++ b/dev-libs/liblognorm/metadata.xml
@@ -14,6 +14,9 @@
<email>maksbotan@gentoo.org</email>
<name>Maxim Koltsov</name>
</maintainer>
+ <slots>
+ <subslots>Reflect ABI of liblognorm.so.</subslots>
+ </slots>
<upstream>
<bugs-to>https://github.com/rsyslog/liblognorm/issues</bugs-to>
<remote-id type="github">rsyslog/liblognorm</remote-id>