summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libofx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libofx')
-rw-r--r--dev-libs/libofx/Manifest2
-rw-r--r--dev-libs/libofx/files/libofx-0.9.5-gcc47.patch11
-rw-r--r--dev-libs/libofx/libofx-0.9.10.ebuild46
-rw-r--r--dev-libs/libofx/libofx-0.9.5.ebuild47
-rw-r--r--dev-libs/libofx/metadata.xml10
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-libs/libofx/Manifest b/dev-libs/libofx/Manifest
new file mode 100644
index 000000000000..8939ecdc7a46
--- /dev/null
+++ b/dev-libs/libofx/Manifest
@@ -0,0 +1,2 @@
+DIST libofx-0.9.10.tar.gz 1433837 SHA256 54e26a4944ef2785087cfd8ed8f187ab9d397d9b92b5acc199dd7d5d095cf695 SHA512 061110702034dbbb9be3adaebe6236a4b0842169d8ee7671bad6c93960b380cbb33953bdf080c8b14f45930b0c817fcfe1bf71f15d9872dd2535a1415f5be895 WHIRLPOOL 2cf39474bde30086b51529d4fccae51c6b1728b413ddf45768283e1404d0b8bb0316a532c3a1436dfee22d4953df8ef42470bf4414cbd1aef7b9fb7c8661ce38
+DIST libofx-0.9.5.tar.gz 1526857 SHA256 a075c5634b94bad16f8c949eeb77625d31bedea3bb10a8da174b989ffab7e78e SHA512 f7c6e0d85ee1f01216678ec51939ffe09c4a4c5ccc97a5928be45bd2be27418a95004a8a46f17225366908cdd8bb43b19bf95295f0e6422802d3a935a63eb0a9 WHIRLPOOL 67f61361417636e297f45f7c9d3d4de9e88a20c9af4b1a6f811d4b6d6d671f045f3f485b193d24372e89fdbfbd944565bb3ec224578351c1d31cf9c109921d5f
diff --git a/dev-libs/libofx/files/libofx-0.9.5-gcc47.patch b/dev-libs/libofx/files/libofx-0.9.5-gcc47.patch
new file mode 100644
index 000000000000..2e6ee8b08d65
--- /dev/null
+++ b/dev-libs/libofx/files/libofx-0.9.5-gcc47.patch
@@ -0,0 +1,11 @@
+diff -ruN libofx-0.9.5.orig/ofxconnect/ofxpartner.cpp libofx-0.9.5/ofxconnect/ofxpartner.cpp
+--- libofx-0.9.5.orig/ofxconnect/ofxpartner.cpp 2011-03-31 00:30:50.000000000 +0200
++++ libofx-0.9.5/ofxconnect/ofxpartner.cpp 2012-06-30 21:57:35.747989782 +0200
+@@ -37,6 +37,7 @@
+ #include <vector>
+ #include <algorithm>
+ #include <string.h>
++#include <unistd.h>
+
+ using std::string;
+ using std::vector;
diff --git a/dev-libs/libofx/libofx-0.9.10.ebuild b/dev-libs/libofx/libofx-0.9.10.ebuild
new file mode 100644
index 000000000000..2fc03e9b549e
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.9.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A library to support the Open Financial eXchange XML format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ >=app-text/opensp-1.5
+ dev-cpp/libxmlpp:2.6
+ >=net-misc/curl-7.9.7
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( app-crypt/gnupg )
+"
+
+src_prepare() {
+ autotools-utils_src_prepare
+
+ # Be sure DTD gets installed in correct path after redefining docdir in install
+ sed -i \
+ -e 's:$(DESTDIR)$(docdir):$(DESTDIR)$(LIBOFX_DTD_DIR):' \
+ dtd/Makefile.in || die
+
+ # configure arguments alone don't disable everything
+ sed -e "/^SUBDIRS/s/doc//" -i Makefile.in || die
+}
+
+src_install() {
+ autotools-utils_src_install docdir="/usr/share/doc/${PF}"
+
+ rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+}
diff --git a/dev-libs/libofx/libofx-0.9.5.ebuild b/dev-libs/libofx/libofx-0.9.5.ebuild
new file mode 100644
index 000000000000..ec7f03d27b96
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="A library to support the Open Financial eXchange XML format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc ~ppc64 x86"
+IUSE="doc static-libs test"
+
+RDEPEND=">=app-text/opensp-1.5
+ dev-cpp/libxmlpp:2.6
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( sys-apps/help2man )
+ test? ( app-crypt/gnupg )"
+
+PATCHES=( "${FILESDIR}/${P}-gcc47.patch" )
+
+src_prepare() {
+ base_src_prepare
+ # Be sure DTD gets installed in correct path after redefining docdir in install
+ sed -i \
+ -e 's:$(DESTDIR)$(docdir):$(DESTDIR)$(LIBOFX_DTD_DIR):' \
+ dtd/Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-doxygen
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install
+
+ rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-libs/libofx/metadata.xml b/dev-libs/libofx/metadata.xml
new file mode 100644
index 000000000000..6533c91bafd2
--- /dev/null
+++ b/dev-libs/libofx/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">libofx</remote-id>
+ </upstream>
+</pkgmetadata>