summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libowfat/libowfat-0.29.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libowfat/libowfat-0.29.ebuild')
-rw-r--r--dev-libs/libowfat/libowfat-0.29.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/libowfat/libowfat-0.29.ebuild b/dev-libs/libowfat/libowfat-0.29.ebuild
new file mode 100644
index 000000000000..dcaef4b07e25
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.29.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein"
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE="diet"
+
+RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+pkg_setup() {
+ # Required for mult/umult64.c to be usable
+ append-flags -fomit-frame-pointer
+}
+
+src_prepare() {
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET?=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ -i GNUmakefile || die "sed failed"
+ epatch "${FILESDIR}/libowfat-0.28-GNUmakefile.patch"
+}
+
+src_compile() {
+ emake -j1 \
+ CC=$(tc-getCC) \
+ $( use diet || echo 'DIET=' )
+}
+
+src_install () {
+ emake -j1 \
+ LIBDIR="${D}/usr/lib" \
+ MAN3DIR="${D}/usr/share/man/man3" \
+ INCLUDEDIR="${D}/usr/include/libowfat" \
+ install || die "emake install failed"
+
+ cd "${D}"/usr/share/man
+ mv man3/buffer.3 man3/owfat-buffer.3
+}