summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-10-29 02:39:00 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-10-29 02:39:16 +0300
commitaa95525771b2d44a7d8f3c4d9c8e9d38c42f32d3 (patch)
tree1e246461f41b47fd99722d7dd3632f735d48ed8c /dev-libs/libp11
parentdev-util/bazel: add package (diff)
downloadgentoo-aa95525771b2d44a7d8f3c4d9c8e9d38c42f32d3.tar.gz
gentoo-aa95525771b2d44a7d8f3c4d9c8e9d38c42f32d3.tar.bz2
gentoo-aa95525771b2d44a7d8f3c4d9c8e9d38c42f32d3.zip
dev-libs/libp11: version bump
Bug: 598394 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/libp11')
-rw-r--r--dev-libs/libp11/Manifest1
-rw-r--r--dev-libs/libp11/libp11-0.4.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libp11/Manifest b/dev-libs/libp11/Manifest
index be0fb11751da..ad744009cc83 100644
--- a/dev-libs/libp11/Manifest
+++ b/dev-libs/libp11/Manifest
@@ -1 +1,2 @@
DIST libp11-0.2.8.tar.gz 377508 SHA256 a4121015503ade98074b5e2a2517fc8a139f8b28aed10021db2bb77283f40691 SHA512 917c6623942c83e7657c9b9c4ce0482ffc4539fc29edec9ace412dcece640be3785bf82e09e344c0866b55619ea011ab829ef3d4f8205f2019121d837b1d6c17 WHIRLPOOL fe4f8c6ce952e8a0985bf90af1413c0ba2c2ac84309b1cad55c12f65aa77655e4b9154e1af53d55ba968f9c88a960efd44a4033bcbaa309958f35327eeeac0d9
+DIST libp11-0.4.2.tar.gz 438887 SHA256 e2c3614a314b452a9b57e2914252df3ffee59e262dfb75b4fc73a2247f8ddebe SHA512 086845e8d1094ada8c301776e0231904e3cdaa28df6e8621490f8cbb0925ae8f8d9381ae1000f60686effa89bfbb34ccc013a77156d15718f269495260f125a2 WHIRLPOOL ddcc49a2ec00fcf8dbcb0bf3a915946c0d8f126be74d5bb2942cf9667b8fbe549031ed75839e57731fec96febeb02a03a129707ee01456b70a06bb008babe5bf
diff --git a/dev-libs/libp11/libp11-0.4.2.ebuild b/dev-libs/libp11/libp11-0.4.2.ebuild
new file mode 100644
index 000000000000..8a4218a8deb7
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils
+
+DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl doc static-libs"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}