summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-14 22:05:24 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-14 22:05:42 +0100
commit25ef6b909739e2427840d145c65da06e16dbcb8c (patch)
treea8358a7b5792d0ce89714d52d487953d08c2ae56 /dev-libs/libpcre2
parentsys-apps/portage: sync prefix repos.conf sed (diff)
downloadgentoo-25ef6b909739e2427840d145c65da06e16dbcb8c.tar.gz
gentoo-25ef6b909739e2427840d145c65da06e16dbcb8c.tar.bz2
gentoo-25ef6b909739e2427840d145c65da06e16dbcb8c.zip
dev-libs/libpcre2: Bump to version 10.23
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libpcre2')
-rw-r--r--dev-libs/libpcre2/Manifest1
-rw-r--r--dev-libs/libpcre2/libpcre2-10.23.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/libpcre2/Manifest b/dev-libs/libpcre2/Manifest
index d5f0f423aefa..1b257c8d41f2 100644
--- a/dev-libs/libpcre2/Manifest
+++ b/dev-libs/libpcre2/Manifest
@@ -1 +1,2 @@
DIST pcre2-10.22.tar.bz2 1470620 SHA256 b2b44619f4ac6c50ad74c2865fd56807571392496fae1c9ad7a70993d018f416 SHA512 dcf70b5e5b73f29188a56e4d9efb9afdf2b9ebe50e13a7640b80f543851235a289e476e1f517f49fac9628b456268bcdaf2b492237bc879ddff36f84ef4f32ea WHIRLPOOL 154ee1c4d2445878c2d2fd1eafa96584d8c943e9e545937b37d4c1fb12ba847938647184723d429244bf5aa989ba335cfbf74fadb5d38227862762bd34166232
+DIST pcre2-10.23.tar.bz2 1515314 SHA256 dfc79b918771f02d33968bd34a749ad7487fa1014aeb787fad29dd392b78c56e SHA512 3e5910bd2405cc35934d91e4be760abe4f2e900202a20b6ba74adb7a3acb2b74b3bf9b0e97e8de10f8e8534133e0722e0bf0f5fb40d6c2c4520d1ed61749d456 WHIRLPOOL 8db3deb22c26688607e1dc4b52229c64f8bcbb80908155ff9bd58b690a239984b6f5d1aff0cdc70efa3abf3ee899e22ea6e3a502437af424cb92d345133889a6
diff --git a/dev-libs/libpcre2/libpcre2-10.23.ebuild b/dev-libs/libpcre2/libpcre2-10.23.ebuild
new file mode 100644
index 000000000000..bd997225ea5a
--- /dev/null
+++ b/dev-libs/libpcre2/libpcre2-10.23.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils libtool flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+MY_P="pcre2-${PV/_rc/-RC}"
+if [[ ${PV} != *_rc* ]] ; then
+ # Only the final releases are available here.
+ SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
+ ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+else
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 +jit libedit pcre16 pcre32 +readline +recursion-limit static-libs unicode zlib"
+REQUIRED_USE="?? ( libedit readline )"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )
+ libedit? ( dev-libs/libedit )
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pcre2-config
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
+ $(multilib_native_use_enable bzip2 pcre2grep-libbz2) \
+ $(use_enable jit) $(use_enable jit pcre2grep-jit) \
+ $(use_enable pcre16 pcre2-16) \
+ $(use_enable pcre32 pcre2-32) \
+ $(multilib_native_use_enable libedit pcre2test-libedit) \
+ $(multilib_native_use_enable readline pcre2test-libreadline) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode) \
+ $(multilib_native_use_enable zlib pcre2grep-libz) \
+ --enable-pcre2-8 \
+ --enable-shared \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+multilib_src_compile() {
+ emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
+ install
+ multilib_is_native_abi && gen_usr_ldscript -a pcre2-posix
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}