summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-17 10:37:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-17 10:37:38 +0200
commiteebadd9462896cfe9fe04ab045d966b2184b44d5 (patch)
tree2596bf7b76c3e9ea9ff9c267c01c0aa9c99627d3 /dev-libs/libpcre2
parentdev-vcs/mercurial: Security cleanup (diff)
downloadgentoo-eebadd9462896cfe9fe04ab045d966b2184b44d5.tar.gz
gentoo-eebadd9462896cfe9fe04ab045d966b2184b44d5.tar.bz2
gentoo-eebadd9462896cfe9fe04ab045d966b2184b44d5.zip
dev-libs/libpcre2: Bump to version 10.33
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libpcre2')
-rw-r--r--dev-libs/libpcre2/Manifest1
-rw-r--r--dev-libs/libpcre2/libpcre2-10.33.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/libpcre2/Manifest b/dev-libs/libpcre2/Manifest
index 08483bc57e60..7c4af4b53803 100644
--- a/dev-libs/libpcre2/Manifest
+++ b/dev-libs/libpcre2/Manifest
@@ -1,3 +1,4 @@
DIST pcre2-10.30.tar.bz2 1583543 BLAKE2B bd9369f3c81bf0d154aaf3d111b934835af25068051f9bcafc0d4b00376011ff7a4acfac127ee10efe6094021163a07a073076d9d769eff68823fd8d1041cd1f SHA512 f247a9f917c75920793b9919a45bb1426d126246e7a5d04e39d9407e44b5781f894a90cd3d232b385436b2f22be391335ab782664dd3a28c79058a2fcc74dc3e
DIST pcre2-10.31.tar.bz2 1603075 BLAKE2B 3cc101b738320823f5b8ab5d29fcc94d8bc2ecd3fbade148de34eda5371cc4d9c168f9e234f0d581626f3da85988ec8d46f76377b019459d3f6b044998e82426 SHA512 44d7db2513d9415dcdf6541366fea585e016f572f3e4379f6e959a38114b2337851092049ab4a1576ae8f19b9de413edbcfa62f434c77fc8470747ee5413e967
DIST pcre2-10.32.tar.bz2 1641814 BLAKE2B fdd512312547ae90b36b6c9eb86b6fcfea9b03fcfd9766063c901819c6bf7536e1f3da89bd69ae62309069bc07c705e96e81f4a36355bf934c566f343e3104e4 SHA512 3d712e7d6afbaef227952680ded69fadbdec0b1abdfcac17cf071415c3c93edd152d6d268dec80570aedf24f82ba954f74f5f9e62c9b9991be75080a3d6ab5fe
+DIST pcre2-10.33.tar.bz2 1690739 BLAKE2B e59cf47a5068b2ec2d647d6dfe1cb5f8d6cdcc6fc6b47aa65a4c3d5aae256e7f0b090487d372c62aa7ec7f15a1f037650088b53385fc2fe31aa405878855e5d5 SHA512 c6aa52cdbb0c906b02e9a9f255697a1b9b99d9c7dccdaa484ffdb04fe3582d232ba3cb3c421d6df589a387b415dedb0817f58ec5391488b25b4e7bd9da6bab8f
diff --git a/dev-libs/libpcre2/libpcre2-10.33.ebuild b/dev-libs/libpcre2/libpcre2-10.33.ebuild
new file mode 100644
index 000000000000..4d229a789ef8
--- /dev/null
+++ b/dev-libs/libpcre2/libpcre2-10.33.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic libtool multilib-minimal toolchain-funcs
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+MY_P="pcre2-${PV/_rc/-RC}"
+if [[ ${PV} != *_rc* ]] ; then
+ # Only the final releases are available here.
+ SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
+ ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+else
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 +jit libedit pcre16 pcre32 +readline +recursion-limit static-libs unicode zlib"
+REQUIRED_USE="?? ( libedit readline )"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )
+ libedit? ( dev-libs/libedit )
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
+
+S="${WORKDIR}/${MY_P}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pcre2-config
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-pcre2-8
+ --enable-shared
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --with-match-limit-depth=$(usex recursion-limit 8192 MATCH_LIMIT)
+ $(multilib_native_use_enable bzip2 pcre2grep-libbz2)
+ $(multilib_native_use_enable libedit pcre2test-libedit)
+ $(multilib_native_use_enable readline pcre2test-libreadline)
+ $(multilib_native_use_enable zlib pcre2grep-libz)
+ $(use_enable jit)
+ $(use_enable jit pcre2grep-jit)
+ $(use_enable pcre16 pcre2-16)
+ $(use_enable pcre32 pcre2-32)
+ $(use_enable static-libs static)
+ $(use_enable unicode)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
+}
+
+multilib_src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
+ install
+ multilib_is_native_abi && gen_usr_ldscript -a pcre2-posix
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+}