summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-24 10:16:04 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-24 10:16:18 +0100
commit0c7a27b6c22be81ce8ce7f1af8232daafeb0e682 (patch)
treec1404023ec533de473706e17f7183514e11f241d /dev-libs/libpcre
parentdev-libs/libpcre: Bump to version 8.38 (diff)
downloadgentoo-0c7a27b6c22be81ce8ce7f1af8232daafeb0e682.tar.gz
gentoo-0c7a27b6c22be81ce8ce7f1af8232daafeb0e682.tar.bz2
gentoo-0c7a27b6c22be81ce8ce7f1af8232daafeb0e682.zip
dev-libs/libpcre: Removed old.
Package-Manager: portage-2.2.25 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/libpcre-8.37-r1.ebuild92
-rw-r--r--dev-libs/libpcre/libpcre-8.37.ebuild96
2 files changed, 0 insertions, 188 deletions
diff --git a/dev-libs/libpcre/libpcre-8.37-r1.ebuild b/dev-libs/libpcre/libpcre-8.37-r1.ebuild
deleted file mode 100644
index f1689c796fb9..000000000000
--- a/dev-libs/libpcre/libpcre-8.37-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils multilib libtool flag-o-matic toolchain-funcs multilib-minimal
-
-DESCRIPTION="Perl-compatible regular expression library"
-HOMEPAGE="http://www.pcre.org/"
-MY_P="pcre-${PV/_rc/-RC}"
-if [[ ${PV} != *_rc* ]] ; then
- # Only the final releases are available here.
- SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
- ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
-else
- SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
-fi
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 +cxx +jit libedit pcre16 pcre32 +readline +recursion-limit static-libs unicode zlib"
-REQUIRED_USE="readline? ( !libedit )
- libedit? ( !readline )"
-
-RDEPEND="bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )
- libedit? ( dev-libs/libedit )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
-RDEPEND="${RDEPEND}
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r2
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-S=${WORKDIR}/${MY_P}
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pcre-config
-)
-
-src_prepare() {
- sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
- elibtoolize
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
- $(multilib_native_use_enable bzip2 pcregrep-libbz2) \
- $(use_enable cxx cpp) \
- $(use_enable jit) $(use_enable jit pcregrep-jit) \
- $(use_enable pcre16) \
- $(use_enable pcre32) \
- $(multilib_native_use_enable libedit pcretest-libedit) \
- $(multilib_native_use_enable readline pcretest-libreadline) \
- $(use_enable static-libs static) \
- $(use_enable unicode utf) $(use_enable unicode unicode-properties) \
- $(multilib_native_use_enable zlib pcregrep-libz) \
- --enable-pcre8 \
- --enable-shared \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
-}
-
-multilib_src_compile() {
- emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
-}
-
-multilib_src_install() {
- emake \
- DESTDIR="${D}" \
- $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
- install
- multilib_is_native_abi && gen_usr_ldscript -a pcre
-}
-
-multilib_src_install_all() {
- prune_libtool_files
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/libpcre.so.0
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/libpcre.so.0
-}
diff --git a/dev-libs/libpcre/libpcre-8.37.ebuild b/dev-libs/libpcre/libpcre-8.37.ebuild
deleted file mode 100644
index 1d284f51964b..000000000000
--- a/dev-libs/libpcre/libpcre-8.37.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils multilib libtool flag-o-matic toolchain-funcs multilib-minimal
-
-DESCRIPTION="Perl-compatible regular expression library"
-HOMEPAGE="http://www.pcre.org/"
-MY_P="pcre-${PV/_rc/-RC}"
-if [[ ${PV} != *_rc* ]] ; then
- # Only the final releases are available here.
- SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
- ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
-else
- SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
-fi
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 +cxx +jit libedit pcre16 pcre32 +readline +recursion-limit static-libs unicode zlib"
-REQUIRED_USE="readline? ( !libedit )
- libedit? ( !readline )"
-
-RDEPEND="bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )
- libedit? ( dev-libs/libedit )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
-RDEPEND="${RDEPEND}
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r2
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-S=${WORKDIR}/${MY_P}
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/pcre-config
-)
-
-src_prepare() {
- local pc
- for pc in *.pc.in ; do
- echo "Libs.private: @PTHREAD_CFLAGS@" >> ${pc} #454478
- done
- sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
- elibtoolize
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
- $(multilib_native_use_enable bzip2 pcregrep-libbz2) \
- $(use_enable cxx cpp) \
- $(use_enable jit) $(use_enable jit pcregrep-jit) \
- $(use_enable pcre16) \
- $(use_enable pcre32) \
- $(multilib_native_use_enable libedit pcretest-libedit) \
- $(multilib_native_use_enable readline pcretest-libreadline) \
- $(use_enable static-libs static) \
- $(use_enable unicode utf) $(use_enable unicode unicode-properties) \
- $(multilib_native_use_enable zlib pcregrep-libz) \
- --enable-pcre8 \
- --enable-shared \
- --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
-}
-
-multilib_src_compile() {
- emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
-}
-
-multilib_src_install() {
- emake \
- DESTDIR="${D}" \
- $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
- install
- multilib_is_native_abi && gen_usr_ldscript -a pcre
-}
-
-multilib_src_install_all() {
- prune_libtool_files
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/libpcre.so.0
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/libpcre.so.0
-}