summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-04 01:31:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-17 21:58:53 +0200
commit0902eba3032f998a6ae627554e4d35ef1f2d29b3 (patch)
treeeaca909b218662ee81997a3148d4db67e37b99d9 /dev-libs/libpqxx/libpqxx-5.1.0.ebuild
parentdev-cpp/websocketpp: Whitespace (diff)
downloadgentoo-0902eba3032f998a6ae627554e4d35ef1f2d29b3.tar.gz
gentoo-0902eba3032f998a6ae627554e4d35ef1f2d29b3.tar.bz2
gentoo-0902eba3032f998a6ae627554e4d35ef1f2d29b3.zip
dev-libs/libpqxx: Cleanup, indendation, add missing die
Fix src_* order. Closes: https://github.com/gentoo/gentoo/pull/5218 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libpqxx/libpqxx-5.1.0.ebuild')
-rw-r--r--dev-libs/libpqxx/libpqxx-5.1.0.ebuild42
1 files changed, 17 insertions, 25 deletions
diff --git a/dev-libs/libpqxx/libpqxx-5.1.0.ebuild b/dev-libs/libpqxx/libpqxx-5.1.0.ebuild
index 6c01ca8a607a..83c831e8738d 100644
--- a/dev-libs/libpqxx/libpqxx-5.1.0.ebuild
+++ b/dev-libs/libpqxx/libpqxx-5.1.0.ebuild
@@ -16,12 +16,12 @@ SLOT="0"
IUSE="doc static-libs"
RDEPEND="dev-db/postgresql:="
-DEPEND="${PYTHON_DEPS}
- ${RDEPEND}
- doc? (
- app-doc/doxygen
- app-text/xmlto
- )
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? (
+ app-doc/doxygen
+ app-text/xmlto
+ )
"
DOCS=( AUTHORS NEWS README{.md,-UPGRADE} )
@@ -41,16 +41,6 @@ src_configure() {
$(use_enable static-libs static)
}
-src_install () {
- use doc && HTML_DOCS=( doc/html/. )
-
- default
-
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
-}
-
src_test() {
einfo "The tests need a running PostgreSQL server and an existing database."
einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
@@ -71,15 +61,8 @@ src_test() {
local server_version
server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
if [[ $? = 0 ]] ; then
- # Currently works with highest server version in tree
- #server_version=$(echo ${server_version} | cut -d " " -f 2 | cut -d "." -f -2 | tr -d .)
- #if [[ $server_version < 92 ]] ; then
- cd "${S}/test"
- emake check
- #else
- # eerror "Server version must be 8.4.x or below."
- # die "Server version isn't 8.4.x or below"
- #fi
+ cd "${S}/test" || die
+ emake check
else
eerror "Is the server running?"
eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
@@ -92,3 +75,12 @@ src_test() {
eerror "Skipping tests."
fi
}
+
+src_install () {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}