summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-22 01:32:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-22 01:32:56 +0200
commitddef29c037229fa7339e39e9fcdc963eeb8d13e8 (patch)
tree02be63540147ec7a0eec12c865d37db39161a6a3 /dev-libs/libratbag/libratbag-0.9.ebuild
parentapp-vim/python-mode: version bump. (diff)
downloadgentoo-ddef29c037229fa7339e39e9fcdc963eeb8d13e8.tar.gz
gentoo-ddef29c037229fa7339e39e9fcdc963eeb8d13e8.tar.bz2
gentoo-ddef29c037229fa7339e39e9fcdc963eeb8d13e8.zip
dev-libs/libratbag: Initial commit.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libratbag/libratbag-0.9.ebuild')
-rw-r--r--dev-libs/libratbag/libratbag-0.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libratbag/libratbag-0.9.ebuild b/dev-libs/libratbag/libratbag-0.9.ebuild
new file mode 100644
index 000000000000..0430e0fe0a14
--- /dev/null
+++ b/dev-libs/libratbag/libratbag-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson udev
+
+DESCRIPTION="Library to configure gaming mice"
+HOMEPAGE="https://github.com/libratbag/libratbag"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/libevdev
+ virtual/libudev
+"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-documentation=$(usex doc true false)
+ -Denable-tests=$(usex test true false)
+ -Dudev-dir=$(get_udevdir)
+ )
+ meson_src_configure
+}