summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-09-07 15:16:07 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-09-07 15:16:07 -0400
commit81c31dc390f82432736baef8e9d19e1087da5f73 (patch)
treec395cdd5ccc37f6bfaa2d0ac140f7b9241a73dc2 /dev-libs/libressl
parentmedia-video/ffmpeg: arm stable, bug #627018 (diff)
downloadgentoo-81c31dc390f82432736baef8e9d19e1087da5f73.tar.gz
gentoo-81c31dc390f82432736baef8e9d19e1087da5f73.tar.bz2
gentoo-81c31dc390f82432736baef8e9d19e1087da5f73.zip
dev-libs/libressl: version bump to 2.6.1
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-2.6.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index baefa7e7a9b2..1f62bbcdc291 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -4,3 +4,4 @@ DIST libressl-2.5.0.tar.gz 3012855 SHA256 8652bf6b55ab51fb37b686a3f604a2643e0e8f
DIST libressl-2.5.4.tar.gz 3286042 SHA256 107a5b522fbb8318d4c3be668075e5e607296f0a9255d71674caa94571336efa SHA512 8ca86c14af0020c90bef4651892799864938dab9d898172269cb78bad5963314e064f2b4c46e6a04e0b85d1eddbd1840b734803c11ceec8fd6bb1290e0fe204c WHIRLPOOL f1cfb1b126759275172616eadbc40e20ae8bbc615bfa4e49e68b3c5a9f66e6503007531a2ff59df482ebf6902008b431ca5891d73e6c8887862f11e00f76b423
DIST libressl-2.5.5.tar.gz 3283158 SHA256 e57f5e3d5842a81fe9351b6e817fcaf0a749ca4ef35a91465edba9e071dce7c4 SHA512 3f576e74ddea17bd72e1bfbe0b57b94e1a2a9e6fa56cee50624cd8d18f0a8674273086225669e6ece56e6b859d2376e36e2c140d37acb52d4cd79374c4ba7096 WHIRLPOOL 1700ef95f11677936d23f06da586ecc7e4f7daeed1d2878c0517c2f4e9e64db9dac0f88bdee423b7cbe3dd47707a8bfbe1bca79abd84957afe5a715e6ac8924b
DIST libressl-2.6.0.tar.gz 3297288 SHA256 e48d557474571792699000c32ae97dcef34207d13ed93e4126f213d5dcbe8a53 SHA512 e195c6a2c9680cfaaca31bb6d3392fc6f725efd2a2d18b9a24d457d035a581c88630e6a066a4a4e0903e71f3ae3c30a031eb4f58281e483fdf1d877227452e9a WHIRLPOOL b9e481f9ea6c9c35438d093883f2794a3d4a3b4e34beef2df03bf32674cb0b61709381f6810f31fe31f2e4b784c90e1a263e75e5eda2f822ca77969f32a22469
+DIST libressl-2.6.1.tar.gz 3219005 SHA256 c293b3b5f1fc1d6349c019c3905355d577df32734b631d7e656503894e09127e SHA512 89f1a796c14bd479f20407254a0d787b4200b3b633f5c24e23f16751ff973ccbf3167d676ed13a5004614b5c8c3e1c73c89dce3d5b1e81890ef6ef2774df9b72 WHIRLPOOL 8623863d710bba80f5b90802f06e302960a22bc846946b4c5d2581677f59c37cf59a4d1e5fad787b8bd41b2d3d994d60c6065504cdb71a90cf5b299c2081d8cc
diff --git a/dev-libs/libressl/libressl-2.6.1.ebuild b/dev-libs/libressl/libressl-2.6.1.ebuild
new file mode 100644
index 000000000000..ae81279ce6f1
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/44"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ eapply_user
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}