summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-22 18:57:46 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-22 18:58:01 +0200
commitfd3ff6d5c472bdc8657f80aa077df68190fd9298 (patch)
treee8fc2d799ab139bdff1504bfde933c908387a490 /dev-libs/libspt/libspt-1.1-r4.ebuild
parentapp-office/libreoffice-l10n: Drop 6.0.2.1 (diff)
downloadgentoo-fd3ff6d5c472bdc8657f80aa077df68190fd9298.tar.gz
gentoo-fd3ff6d5c472bdc8657f80aa077df68190fd9298.tar.bz2
gentoo-fd3ff6d5c472bdc8657f80aa077df68190fd9298.zip
dev-libs/libspt: Always use libtirpc now
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libspt/libspt-1.1-r4.ebuild')
-rw-r--r--dev-libs/libspt/libspt-1.1-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libspt/libspt-1.1-r4.ebuild b/dev-libs/libspt/libspt-1.1-r4.ebuild
new file mode 100644
index 000000000000..3c164850c4f9
--- /dev/null
+++ b/dev-libs/libspt/libspt-1.1-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Library for handling root privilege"
+#HOMEPAGE="http://www.j10n.org/libspt/index.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="suid"
+RESTRICT="test"
+
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-gentoo.patch"
+ "${FILESDIR}/${PN}-rpc.patch"
+)
+
+src_prepare() {
+ rm aclocal.m4
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-libtirpc
+}
+
+src_install() {
+ default
+
+ if use suid; then
+ fperms 4755 /usr/libexec/sptagent
+ fi
+}