summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild')
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild b/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild
new file mode 100644
index 000000000000..c7a509beee78
--- /dev/null
+++ b/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="libsqlora8 is a simple C-library to access Oracle databases via the OCI interface"
+SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
+HOMEPAGE="http://www.poitschke.de/libsqlora8/index_noframe.html"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="threads orathreads"
+
+DEPEND=""
+
+pkg_setup() {
+ if use orathreads && use threads; then
+ eerror
+ eerror 'Enable the "threads" USE flag for POSIX threads,'
+ eerror '*or* the "orathreads" USE flag for Oracle threads'
+ eerror
+ die 'Both "threads" and "orathreads" USE flags set, see above'
+ fi
+
+ # Make sure ORACLE_HOME is set
+ if [ -z "${ORACLE_HOME}" ]; then
+ eerror
+ eerror 'libsqlora8 requires that the ORACLE_HOME environment variable be set.'
+ eerror 'Try: "export ORACLE_HOME=/usr/local/oracle" if you do not know what to do.'
+ eerror
+ die 'ORACLE_HOME not set, see above'
+ fi
+}
+
+src_compile() {
+ local myconf;
+
+ # Add $ORACLE_HOME/lib to LD_LIBRARY_PATH
+ if [ -z "${LD_LIBRARY_PATH}" ]; then
+ LD_LIBRARY_PATH=${ORACLE_HOME}/lib
+ else
+ LD_LIBRARY_PATH=${ORACLE_HOME}/lib:${LD_LIBRARY_PATH}
+ fi
+
+ export LD_LIBRARY_PATH
+
+ use threads && myconf="--with-threads=posix"
+ use orathreads && myconf="--with-threads=oracle"
+
+ # Build
+ econf ${myconf} || die "configure failed"
+ emake
+}
+
+src_install () {
+ einstall
+ dodoc ChangeLog NEWS NEWS-2.2
+
+ # TODO
+ # Copy contents of doc and examples directory to doc
+}