summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-04-13 15:54:04 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-04-13 17:46:06 +0300
commit99137f11feb22edc583aa2dc2a13243dc5e9c650 (patch)
tree599fc70526c4b956908ff69dfb783ce81ef6d856 /dev-libs/libtecla/libtecla-1.6.3.ebuild
parentprofiles/base/package.use.stable.mask: mask dev-lang/go[gccgo] (diff)
downloadgentoo-99137f11feb22edc583aa2dc2a13243dc5e9c650.tar.gz
gentoo-99137f11feb22edc583aa2dc2a13243dc5e9c650.tar.bz2
gentoo-99137f11feb22edc583aa2dc2a13243dc5e9c650.zip
dev-libs/libtecla: version bump
- fix parallel build failure (bug 514506); - update to EAPI=6; - update rework patches so that they are suitable for upstream. Package-Manager: portage-2.2.28 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'dev-libs/libtecla/libtecla-1.6.3.ebuild')
-rw-r--r--dev-libs/libtecla/libtecla-1.6.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libtecla/libtecla-1.6.3.ebuild b/dev-libs/libtecla/libtecla-1.6.3.ebuild
new file mode 100644
index 000000000000..f7c235d022d4
--- /dev/null
+++ b/dev-libs/libtecla/libtecla-1.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Tecla command-line editing library"
+HOMEPAGE="http://www.astro.caltech.edu/~mcs/tecla/"
+SRC_URI="http://www.astro.caltech.edu/~mcs/tecla/${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/libtecla
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-install.patch
+ "${FILESDIR}"/${PN}-1.6.1-no-strip.patch
+ "${FILESDIR}"/${PN}-1.6.3-ldflags.patch
+ "${FILESDIR}"/${PN}-1.6.3-prll-build.patch
+ "${FILESDIR}"/${PN}-1.6.1-prll-install.patch
+ "${FILESDIR}"/${PN}-1.6.3-static-libs.patch
+ "${FILESDIR}"/${PN}-1.6.3-secure-runpath.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs)
+}
+
+src_compile() {
+ emake \
+ OPT="" \
+ LDFLAGS="${LDFLAGS}" \
+ LFLAGS="$(raw-ldflags)"
+}