summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-12-15 09:11:57 +0100
committerJeroen Roovers <jer@gentoo.org>2017-12-15 09:12:23 +0100
commit02beaf2561fa74a73ed17336905b720ca3234482 (patch)
tree09288f7cc13f5cd482695bd731d6bb5110717ba6 /dev-libs/libtommath
parentapp-backup/spideroak-bin: fix Manifest, bug #637956 (diff)
downloadgentoo-02beaf2561fa74a73ed17336905b720ca3234482.tar.gz
gentoo-02beaf2561fa74a73ed17336905b720ca3234482.tar.bz2
gentoo-02beaf2561fa74a73ed17336905b720ca3234482.zip
dev-libs/libtommath: Version bump.
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/Manifest1
-rw-r--r--dev-libs/libtommath/libtommath-1.0.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/libtommath/Manifest b/dev-libs/libtommath/Manifest
index ce4219925a88..1b15f3aaffee 100644
--- a/dev-libs/libtommath/Manifest
+++ b/dev-libs/libtommath/Manifest
@@ -1,2 +1,3 @@
DIST libtommath-0.42.0.tar.gz 1732144 BLAKE2B 624697bfa0bab0244783c3d2c92df2a1c0418611dc7f25989d038a5689beae325a426d8de38967ec856bd1e6f2d9413615333eebbf9316add838deda5b122de3 SHA512 d26e7737e5750530a7b96432502f0d458931e67af528872c46ad8dfc921b8f6ef4b3e05cb07d22bd13a8b24db65812928ae4c381250a4df95f6ca55efc3dae23
+DIST ltm-1.0.1.tar.xz 2210120 BLAKE2B e616f0359a1fffe8e1280dc24df1a83eb568d55f9f8acd0e4016fdd63b8ef10d939a8acbd4d49d70a69adf0e492ea5127200798f02af6af1c30e2e1f57870e3a SHA512 f98f7b0f91268e898803478fd52f578f476d378d096a25e48fa2e291159dc89bd1a6dc7d8c5c2254df840c731e5d009ec9728b72190318b6d1ba2916f5c66fb6
DIST ltm-1.0.tar.xz 2191540 BLAKE2B 8794d81558f8e4236256c12201e03aad423b9e69ebd35fde941bd0e70174509a09973ad5cdf432c5c0cbf43f78693351782d9c2ea1085f2fa2a5bb77bafa89c5 SHA512 da2ced516106fb056373d97f9ac443805c57ebeb0a33982c14703d6dd8c3925e49aeb690b790ba91768ed5d41f5875dc50a3d3435dbb4088cfa3fddee9162082
diff --git a/dev-libs/libtommath/libtommath-1.0.1.ebuild b/dev-libs/libtommath/libtommath-1.0.1.ebuild
new file mode 100644
index 000000000000..d369a6bdc05d
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-1.0.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Optimized and portable routines for integer theoretic applications"
+HOMEPAGE="http://www.libtom.net/"
+SRC_URI="https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DEPEND="sys-devel/libtool"
+
+src_prepare() {
+ default
+ # need libtool for cross compilation. Bug #376643
+ cat <<-EOF > configure.ac
+ AC_INIT(libtommath, 0)
+ AM_INIT_AUTOMAKE
+ LT_INIT
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ touch NEWS README AUTHORS ChangeLog Makefile.am
+ eautoreconf
+ export LT="${S}"/libtool
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+_emake() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ -f makefile.shared \
+ IGNORE_SPEED=1 \
+ LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
+ INCPATH="${EPREFIX}/usr/include" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake test_standalone
+ ./test || die
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+ # We only link against -lc, so drop the .la file.
+ find "${ED}" -name '*.la' -delete
+
+ dodoc changes.txt
+
+ use doc && dodoc *.pdf
+
+ if use examples ; then
+ docinto demo
+ dodoc demo/*.c
+ fi
+}