summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:18:37 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:18:37 +0100
commitbe6170ae88a1baca9e5707affed5e4e4f2dfe44c (patch)
tree7bf9354d57f971fb4df90ca579282aa7ff0bc540 /dev-libs/libtreadstone
parentdev-libs/libstroke: disable static libs (diff)
downloadgentoo-be6170ae88a1baca9e5707affed5e4e4f2dfe44c.tar.gz
gentoo-be6170ae88a1baca9e5707affed5e4e4f2dfe44c.tar.bz2
gentoo-be6170ae88a1baca9e5707affed5e4e4f2dfe44c.zip
dev-libs/libtreadstone: disable static libs
Closes: https://bugs.gentoo.org/726984 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/libtreadstone')
-rw-r--r--dev-libs/libtreadstone/libtreadstone-0.2.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-libs/libtreadstone/libtreadstone-0.2.0.ebuild b/dev-libs/libtreadstone/libtreadstone-0.2.0.ebuild
index 1ab31ea5b9ff..cb7f1d335b75 100644
--- a/dev-libs/libtreadstone/libtreadstone-0.2.0.ebuild
+++ b/dev-libs/libtreadstone/libtreadstone-0.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,3 +16,12 @@ IUSE=""
DEPEND=">=dev-libs/libpo6-0.7.0
>=dev-libs/libe-0.10.0"
RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}