summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan Bergström <bugs@bergstroem.nu>2016-02-04 14:36:27 +1100
committerJohan Bergström <bugs@bergstroem.nu>2016-02-05 09:36:16 +1100
commite56d2b3c4b3b4133195f26e9501d9236771e3897 (patch)
tree13124ec95f3cdbfc5d84f1919ec9f009ac9e2894 /dev-libs/libucl/libucl-0.7.3.ebuild
parentnet-wireless/ubertooth: fixup live ebuild and static-libs (diff)
downloadgentoo-e56d2b3c4b3b4133195f26e9501d9236771e3897.tar.gz
gentoo-e56d2b3c4b3b4133195f26e9501d9236771e3897.tar.bz2
gentoo-e56d2b3c4b3b4133195f26e9501d9236771e3897.zip
dev-libs/libucl: New package
Libucl is a configuration library parser and a set of optional utilities.
Diffstat (limited to 'dev-libs/libucl/libucl-0.7.3.ebuild')
-rw-r--r--dev-libs/libucl/libucl-0.7.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libucl/libucl-0.7.3.ebuild b/dev-libs/libucl/libucl-0.7.3.ebuild
new file mode 100644
index 000000000000..585a76baa977
--- /dev/null
+++ b/dev-libs/libucl/libucl-0.7.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Universal configuration library parser"
+HOMEPAGE="https://github.com/vstakhov/libucl"
+SRC_URI="https://github.com/vstakhov/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="lua +regex signatures static-libs urlfetch utils"
+DEPEND="lua? ( >=dev-lang/lua-5.1:= )
+ signatures? ( dev-libs/openssl:0 )
+ urlfetch? ( net-misc/curl )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/api.md )
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local myeconf=""
+ use urlfetch && myeconf="--with-urls"
+ econf \
+ $(use_enable lua) \
+ $(use_enable regex) \
+ $(use_enable signatures) \
+ $(use_enable utils) \
+ ${myeconf}
+}
+
+src_install() {
+ default
+ use lua && DOCS+=( doc/lua_api.md )
+ # no .a's it seems
+ use static-libs || find "${ED}" -name "*.la" -delete
+}