summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-06-03 15:05:02 -0400
committerCraig Andrews <candrews@gentoo.org>2020-06-03 15:08:31 -0400
commit3ac82734b02001568f19740a29aedb8030f6f0ad (patch)
treeceae8c0b5e8630f484111e57cd0b632e4bd31059 /dev-libs/libudfread
parentdev-qt/qtdeclarative: Drop 5.14.2 (r0) (diff)
downloadgentoo-3ac82734b02001568f19740a29aedb8030f6f0ad.tar.gz
gentoo-3ac82734b02001568f19740a29aedb8030f6f0ad.tar.bz2
gentoo-3ac82734b02001568f19740a29aedb8030f6f0ad.zip
dev-libs/libudfread: add static-libs USE flag
Closes: https://bugs.gentoo.org/726988 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libudfread')
-rw-r--r--dev-libs/libudfread/libudfread-1.0.0-r1.ebuild37
-rw-r--r--dev-libs/libudfread/libudfread-9999.ebuild11
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-libs/libudfread/libudfread-1.0.0-r1.ebuild b/dev-libs/libudfread/libudfread-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..6dd66e41c5cd
--- /dev/null
+++ b/dev-libs/libudfread/libudfread-1.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://code.videolan.org/videolan/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library for reading UDF from raw devices and image files"
+HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+}
diff --git a/dev-libs/libudfread/libudfread-9999.ebuild b/dev-libs/libudfread/libudfread-9999.ebuild
index b3304062e6a9..6dd66e41c5cd 100644
--- a/dev-libs/libudfread/libudfread-9999.ebuild
+++ b/dev-libs/libudfread/libudfread-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Library for reading UDF from raw devices and image files"
@@ -18,7 +18,7 @@ HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
LICENSE="LGPL-2.1+"
SLOT="0"
-IUSE=""
+IUSE="static-libs"
src_prepare() {
default
@@ -28,3 +28,10 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf
}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+}