summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-11 23:10:40 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-11 23:10:40 +0100
commita31fdf10b2123589d65169047841dd1efbb42551 (patch)
tree60781011d63ed32060c9dd6ba94af2da5844959c /dev-libs/libunicode
parentapp-text/xhtml1: EAPI bump (diff)
downloadgentoo-a31fdf10b2123589d65169047841dd1efbb42551.tar.gz
gentoo-a31fdf10b2123589d65169047841dd1efbb42551.tar.bz2
gentoo-a31fdf10b2123589d65169047841dd1efbb42551.zip
dev-libs/libunicode: EAPI bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libunicode')
-rw-r--r--dev-libs/libunicode/libunicode-0.4-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libunicode/libunicode-0.4-r2.ebuild b/dev-libs/libunicode/libunicode-0.4-r2.ebuild
new file mode 100644
index 000000000000..88dcbf104bb1
--- /dev/null
+++ b/dev-libs/libunicode/libunicode-0.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Unicode library"
+HOMEPAGE="https://www.gnome.org/"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/${PN}/${PV}/${P}.gnome.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+ # The build system is too old, regenerate here to fix crossbuild and
+ # respect LDFLAGS and probably other problems too.
+ sed -i -e "/testsuite/d" configure.in || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}