summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-22 11:41:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-22 11:41:00 +0000
commit919db84dd6b12247f12f00fbb37b438f7376ead1 (patch)
tree39e52f0f8ac30fef56fd7c62cee2a477ec438db8 /dev-libs/libxls/libxls-1.5.2-r1.ebuild
parentsys-devel/gcc: 9.2.0: cut 4 patchset (diff)
downloadgentoo-919db84dd6b12247f12f00fbb37b438f7376ead1.tar.gz
gentoo-919db84dd6b12247f12f00fbb37b438f7376ead1.tar.bz2
gentoo-919db84dd6b12247f12f00fbb37b438f7376ead1.zip
dev-libs/libxls: fix undefined 'prune_libtool_files' call, #703480
Reported-by: Andreas Sturmlechner Closes: https://bugs.gentoo.org/703480 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/libxls/libxls-1.5.2-r1.ebuild')
-rw-r--r--dev-libs/libxls/libxls-1.5.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libxls/libxls-1.5.2-r1.ebuild b/dev-libs/libxls/libxls-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..2272ad0499ea
--- /dev/null
+++ b/dev-libs/libxls/libxls-1.5.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A library which can read Excel (xls) files"
+HOMEPAGE="https://github.com/libxls/libxls"
+SRC_URI="https://github.com/libxls/libxls/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/1" # libxlsreader.so.1
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig
+"
+
+RESTRICT=test # test driver is missing
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.0-asprintf.patch
+)
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+}