summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-05-25 18:34:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-05-25 18:35:54 +0200
commit04b157f105b1b346e5838536dc06157d2532dad3 (patch)
treef49101aafc9383423d8471ab5bbcab017a06fa53 /dev-libs/libxmlb
parentdev-python/cppy: cleanup metadata.xml (diff)
downloadgentoo-04b157f105b1b346e5838536dc06157d2532dad3.tar.gz
gentoo-04b157f105b1b346e5838536dc06157d2532dad3.tar.bz2
gentoo-04b157f105b1b346e5838536dc06157d2532dad3.zip
dev-libs/libxmlb: Bump to version 0.3.2
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libxmlb')
-rw-r--r--dev-libs/libxmlb/Manifest1
-rw-r--r--dev-libs/libxmlb/libxmlb-0.3.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index 72068efb329a..088eda1dafd2 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -2,3 +2,4 @@ DIST libxmlb-0.1.15.tar.gz 92923 BLAKE2B 97b6af812397dd279e7e3c038627fcf8228cbfa
DIST libxmlb-0.2.1.tar.gz 98284 BLAKE2B b9bf02560a231837d7837b43f01d8f78c54a80319379a7bfa191f8303b77c35e82d1e2bb57722f1bfe56224d96bd1513cef702a0375eb85a137bff8ca3104c5c SHA512 4e082f036eb62626d1724ac5093ad625f9259e9e81aa40d5ca0589a3a72dadd669c0718ff64dcae094973b6c282b6c8f8ce7212b7e47211f320035bb639ec59d
DIST libxmlb-0.3.0.tar.gz 112097 BLAKE2B a1046ee5c940dfd23a7e3cc07c0deb2be0f18fd416c13df7f467ce98308239191788a1cf18026593862c04645486f4ab332fe71eb96dc5e5abc7909e61451cf0 SHA512 28731c84cab0b1164fc08ea751ee7da22b8f4f278c4950a2d5957cc0dcd4457b6ce47dace25dd7c163a790b7ed2619dd6b4863f8147dc201c18f3433990af2cb
DIST libxmlb-0.3.1.tar.gz 113197 BLAKE2B 1e437cb1d9e58350b591bdb6234be453dfdf80fac72c96764c4ce3b7e1f5ffccc310590c1945bc44fd747f0f0c6caeb6ba95cdbeb29e21a1c5a990f041a10ed9 SHA512 7fc892762c7272cbb11e5cb2b6d936ba802b10aaeab68b33e5c1fbccfdd0019378080d355f1719d946e9b838ac76b77c7229723f692c0dde3de3f94ad62a1842
+DIST libxmlb-0.3.2.tar.gz 113428 BLAKE2B 30f29ebd7522ee2338b4e78e15a544bdf20514e151e63d555be29fca63a3c8251c8d340f778ba1b6b6484c084ab145f9e9d1d4acf037b3f1abad05c5b0101082 SHA512 d4c1cbb8dfd2da9f4b9f436fbba5102f0391df7786a1c0bb1543841eaa5928ac72e6d8125e263be51c69627574bfea70d72624385086879cdbdb44721c0daa3d
diff --git a/dev-libs/libxmlb/libxmlb-0.3.2.ebuild b/dev-libs/libxmlb/libxmlb-0.3.2.ebuild
new file mode 100644
index 000000000000..a4cc4b2a152c
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.3.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # libxmlb.so version
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc introspection stemmer test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-apps/util-linux
+ stemmer? ( dev-libs/snowball-stemmer )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgtkdoc="$(usex doc true false)"
+ -Dintrospection="$(usex introspection true false)"
+ -Dstemmer="$(usex stemmer true false)"
+ -Dtests="$(usex test true false)"
+ )
+ meson_src_configure
+}