summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-04-02 23:26:31 -0500
committerTim Harder <radhermit@gentoo.org>2019-04-02 23:26:31 -0500
commit688e2215c91121f82892eb9a11ea782ebd490d3a (patch)
tree8dd2b5df19cf0b321bb7410453774c913a4c6739 /dev-libs/libyaml
parentsys-apps/moreutils: version bump to 0.63 (diff)
downloadgentoo-688e2215c91121f82892eb9a11ea782ebd490d3a.tar.gz
gentoo-688e2215c91121f82892eb9a11ea782ebd490d3a.tar.bz2
gentoo-688e2215c91121f82892eb9a11ea782ebd490d3a.zip
dev-libs/libyaml: version bump to 0.2.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-libs/libyaml')
-rw-r--r--dev-libs/libyaml/Manifest1
-rw-r--r--dev-libs/libyaml/libyaml-0.2.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libyaml/Manifest b/dev-libs/libyaml/Manifest
index c82040768abb..838b0d453059 100644
--- a/dev-libs/libyaml/Manifest
+++ b/dev-libs/libyaml/Manifest
@@ -1,2 +1,3 @@
DIST libyaml-0.2.1.tar.gz 601443 BLAKE2B 4940d1f0a698a985502d6e1c4d3d064061462642829aecc75a820bebcb7b7e4ae5d62777162063650d24962c93da6449bca791811d0438222d897388ec07c2ea SHA512 f91297c37dbbf03aaff718947474381a4a6a4ee1a39171d7fc32c3710ce55321028f3485ea1fcd52b962da36ed021c0b7ec05718296dca636329a19aecc809b8
+DIST libyaml-0.2.2.tar.gz 79465 BLAKE2B fd37cac256b40b0c5daa32584d271448e5e1c196a7fa7eeda753fb962c7d916b3c415425170d70db67c3f114b27d03fdd67fb4e380c04027198a601e1bd5a094 SHA512 455494591014a97c4371a1f372ad09f0d6e487e4f1d3419c98e9cd2f16d43a0cf9a0787d7250bebee8b8d400df4626f5acd81e90139e54fa574a66ec84964c06
DIST yaml-0.1.7.tar.gz 527518 BLAKE2B 80bb082e22e7f8275924aaa4f8e95eefdc94e929690ddefdba61f50d57d01428990687d2c7bcc5b277888825b8bc0619c572594dae64ce00013adde685f9a8d9 SHA512 1ee5007dd10db137b5ee80f8117f07390ec04af98d087a5f5475dd2b38d87c699b79ab1676e6c7bfa263323fcdf8edd69fada2b0b7f9c57bef4e46cd65f1e975
diff --git a/dev-libs/libyaml/libyaml-0.2.2.ebuild b/dev-libs/libyaml/libyaml-0.2.2.ebuild
new file mode 100644
index 000000000000..4a3f8a2366cb
--- /dev/null
+++ b/dev-libs/libyaml/libyaml-0.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools libtool
+
+DESCRIPTION="YAML 1.1 parser and emitter written in C"
+HOMEPAGE="https://github.com/yaml/libyaml"
+SRC_URI="https://github.com/yaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+src_prepare() {
+ default
+
+ # conditionally remove tests
+ if ! use test; then
+ sed -i -e 's: tests::g' Makefile* || die
+ fi
+
+ elibtoolize # for FreeMiNT
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ docinto examples
+ dodoc tests/example-*.c
+ docompress -x /usr/share/doc/${PF}/examples
+}