summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-09-03 15:28:16 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-03 15:28:32 +1000
commitdbcb0a042eb17aa24e486251e8fe231f9309fcdf (patch)
tree0848d9103a2cb7941beec8e8f771294401efa7b4 /dev-libs/libzip/libzip-1.3.0.ebuild
parentRevert "dev-libs/libgdata: drop old revisions" (diff)
downloadgentoo-dbcb0a042eb17aa24e486251e8fe231f9309fcdf.tar.gz
gentoo-dbcb0a042eb17aa24e486251e8fe231f9309fcdf.tar.bz2
gentoo-dbcb0a042eb17aa24e486251e8fe231f9309fcdf.zip
dev-libs/libzip: version bump 1.3.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libzip/libzip-1.3.0.ebuild')
-rw-r--r--dev-libs/libzip/libzip-1.3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libzip/libzip-1.3.0.ebuild b/dev-libs/libzip/libzip-1.3.0.ebuild
new file mode 100644
index 000000000000..c3a635836edb
--- /dev/null
+++ b/dev-libs/libzip/libzip-1.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for manipulating zip archives"
+HOMEPAGE="https://nih.at/libzip/"
+SRC_URI="https://www.nih.at/libzip/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="bzip2 static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ elibc_musl? ( sys-libs/fts-standalone )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS.md API-CHANGES THANKS )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.0-headers.patch"
+ "${FILESDIR}/${PN}-1.2.0-fts.patch"
+)
+
+src_prepare() {
+ default
+
+ # fails in portage build only
+ sed -i -e "/encryption-nonrandom-aes.*.test/d" regress/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with bzip2)
+}
+
+src_install() {
+ default
+ use static-libs || rm "${ED%/}"/usr/$(get_libdir)/libzip.a || die
+ find "${D}" -name '*.la' -delete || die
+}