summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 21:55:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 21:57:47 +0100
commit34e6aee94f736c0493e3bffa6abcd261e08a207c (patch)
tree010df3a7bcdf4200aa54ab2bc891b1046bcdf1ee /dev-libs/libzip
parentmedia-sound/sidplayfp: Drop old (diff)
downloadgentoo-34e6aee94f736c0493e3bffa6abcd261e08a207c.tar.gz
gentoo-34e6aee94f736c0493e3bffa6abcd261e08a207c.tar.bz2
gentoo-34e6aee94f736c0493e3bffa6abcd261e08a207c.zip
dev-libs/libzip: 1.5.1 version bump for testing
Thanks-to: Hung-Te Lin <hungte@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10846 Closes: https://bugs.gentoo.org/675560 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/libzip')
-rw-r--r--dev-libs/libzip/Manifest1
-rw-r--r--dev-libs/libzip/files/libzip-1.5.1-bzip2.patch53
-rw-r--r--dev-libs/libzip/files/libzip-1.5.1-options.patch50
-rw-r--r--dev-libs/libzip/libzip-1.5.1.ebuild89
4 files changed, 193 insertions, 0 deletions
diff --git a/dev-libs/libzip/Manifest b/dev-libs/libzip/Manifest
index c0eb5a5ea60d..396290996fdd 100644
--- a/dev-libs/libzip/Manifest
+++ b/dev-libs/libzip/Manifest
@@ -1 +1,2 @@
DIST libzip-1.3.0.tar.xz 955876 BLAKE2B 9bb59cb34ed7e85e3161770f0eef7ed1f59fb2f7f648cd201fa5dc6c62339481ad72a71024df443c04ef0c7efe6f00838a3ac316da2ef06c0045ab69ade8f71b SHA512 8e12a23fe62b993ff4592e1b9da152533a363b0603fc1f65e6cbb6121d4260c45f98171effbccb76dec4030b0fcdcd273919755a2496ab462431646ac83bb900
+DIST libzip-1.5.1.tar.xz 717908 BLAKE2B f2c19d3a8d9d60f3a0a9bc06359104187e75bcb59ab2aa06df611b487f0c91c27cf52f24bcc24e3d4358c5fe11882661b245829e6cdee2b39559f728cd20f899 SHA512 92df9490a9910ebb1da49ecaec96f364fce39a779e1bc739f7796b27b3a864301f5e1ba0108947708dda1d90af7a9e751be54cbb8a0de2a04a48f9f3eb728e3d
diff --git a/dev-libs/libzip/files/libzip-1.5.1-bzip2.patch b/dev-libs/libzip/files/libzip-1.5.1-bzip2.patch
new file mode 100644
index 000000000000..9b70eaca8e87
--- /dev/null
+++ b/dev-libs/libzip/files/libzip-1.5.1-bzip2.patch
@@ -0,0 +1,53 @@
+From 028c492c9d45ca29e2fbec79a203ba492016f15e Mon Sep 17 00:00:00 2001
+From: Miklos Vajna <vmiklos@collabora.co.uk>
+Date: Fri, 7 Sep 2018 23:12:36 +0200
+Subject: [PATCH] Add an option to disable bzip2 support
+
+The explicit switch is still on by default, but this way it's possible
+to explicitly disable bzip2 support even if bzip2 is available on the
+system.
+
+This is useful if bzip2 is not needed, but would automatically lead to
+an unwanted dependency.
+---
+ CMakeLists.txt | 19 +++++++++++--------
+ 1 file changed, 11 insertions(+), 8 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 73a34855..879e0f21 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -10,6 +10,7 @@ PROJECT(libzip C)
+ OPTION(ENABLE_GNUTLS "Enable use of GnuTLS" ON)
+ OPTION(ENABLE_OPENSSL "Enable use of OpenSSL" ON)
+ OPTION(ENABLE_COMMONCRYPTO "Enable use of CommonCrypto" ON)
++OPTION(ENABLE_BZIP2 "Enable use of BZip2" ON)
+
+ OPTION(BUILD_TOOLS "Build tools in the src directory (zipcmp, zipmerge, ziptool)" ON)
+ OPTION(BUILD_REGRESS "Build regression tests" ON)
+@@ -186,15 +187,17 @@ IF(ZLIB_VERSION_STRING VERSION_LESS "1.1.2")
+ MESSAGE(FATAL_ERROR "-- ZLIB version too old, please install at least v1.1.2")
+ ENDIF(ZLIB_VERSION_STRING VERSION_LESS "1.1.2")
+
+-FIND_PACKAGE(BZip2)
+-IF(BZIP2_FOUND)
+- SET (HAVE_LIBBZ2 1)
++IF(ENABLE_BZIP2)
++ FIND_PACKAGE(BZip2)
++ IF(BZIP2_FOUND)
++ SET (HAVE_LIBBZ2 1)
+
+- INCLUDE_DIRECTORIES(${BZIP2_INCLUDE_DIR})
+- SET (OPTIONAL_LIBRARY ${BZIP2_LIBRARY})
+-ELSE()
+- MESSAGE(WARNING "-- bzip2 library not found; bzip2 support disabled")
+-ENDIF(BZIP2_FOUND)
++ INCLUDE_DIRECTORIES(${BZIP2_INCLUDE_DIR})
++ SET (OPTIONAL_LIBRARY ${BZIP2_LIBRARY})
++ ELSE()
++ MESSAGE(WARNING "-- bzip2 library not found; bzip2 support disabled")
++ ENDIF(BZIP2_FOUND)
++ENDIF(ENABLE_BZIP2)
+
+ IF (COMMONCRYPTO_FOUND)
+ SET (HAVE_CRYPTO 1)
diff --git a/dev-libs/libzip/files/libzip-1.5.1-options.patch b/dev-libs/libzip/files/libzip-1.5.1-options.patch
new file mode 100644
index 000000000000..0cca187d90a0
--- /dev/null
+++ b/dev-libs/libzip/files/libzip-1.5.1-options.patch
@@ -0,0 +1,50 @@
+From b6e53cce5370fba88299f9ed2944ab8a7a4cef5c Mon Sep 17 00:00:00 2001
+From: Florian Delizy <florian.delizy@gmail.com>
+Date: Tue, 7 Aug 2018 22:09:32 +0800
+Subject: [PATCH] adding BUILD_TOOLS BUILD_REGRESS BUILD_EXAMPLES BUILD_DOC
+ options (default ON)
+
+---
+ CMakeLists.txt | 18 ++++++++++++++++++
+ 1 file changed, 18 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 69e6548e..def25607 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,11 @@ OPTION(ENABLE_GNUTLS "Enable use of GnuTLS" ON)
+ OPTION(ENABLE_OPENSSL "Enable use of OpenSSL" ON)
+ OPTION(ENABLE_COMMONCRYPTO "Enable use of CommonCrypto" ON)
+
++OPTION(BUILD_TOOLS "Build tools in the src directory (zipcmp, zipmerge, ziptool)" ON)
++OPTION(BUILD_REGRESS "Build regression tests" ON)
++OPTION(BUILD_EXAMPLES "Build examples" ON)
++OPTION(BUILD_DOC "Build documentation" ON)
++
+ INCLUDE(CheckFunctionExists)
+ INCLUDE(CheckIncludeFiles)
+ INCLUDE(CheckSymbolExists)
+@@ -234,10 +239,23 @@ ENABLE_TESTING()
+
+ # Targets
+ ADD_SUBDIRECTORY(lib)
++
++IF(BUILD_DOC)
+ ADD_SUBDIRECTORY(man)
++ENDIF()
++
++IF(BUILD_TOOLS)
+ ADD_SUBDIRECTORY(src)
++ENDIF()
++
++IF(BUILD_REGRESS)
+ ADD_SUBDIRECTORY(regress)
++ENDIF()
++
++IF(BUILD_EXAMPLES)
+ ADD_SUBDIRECTORY(examples)
++ENDIF()
++
+
+ # pkgconfig file
+ SET(prefix ${CMAKE_INSTALL_PREFIX})
diff --git a/dev-libs/libzip/libzip-1.5.1.ebuild b/dev-libs/libzip/libzip-1.5.1.ebuild
new file mode 100644
index 000000000000..b0125575cca1
--- /dev/null
+++ b/dev-libs/libzip/libzip-1.5.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils multibuild
+
+DESCRIPTION="Library for manipulating zip archives"
+HOMEPAGE="https://nih.at/libzip/"
+SRC_URI="https://www.nih.at/libzip/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="bzip2 doc gnutls libressl ssl static-libs test"
+
+DEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-options.patch"
+ "${FILESDIR}/${P}-bzip2.patch"
+)
+
+pkg_setup() {
+ # Upstream doesn't support building dynamic & static
+ # simultaneously: https://github.com/nih-at/libzip/issues/76
+ MULTIBUILD_VARIANTS=( shared $(usev static-libs) )
+}
+
+src_configure() {
+ myconfigure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF # nothing is installed
+ -DENABLE_COMMONCRYPTO=OFF # not in tree
+ -DENABLE_BZIP2=$(usex bzip2)
+ )
+ if [[ ${MULTIBUILD_VARIANT} = static-libs ]]; then
+ mycmakeargs+=(
+ -DBUILD_DOC=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_TOOLS=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DBUILD_DOC=$(usex doc)
+ -DBUILD_REGRESS=$(usex test)
+ )
+ fi
+
+ if use ssl; then
+ mycmakeargs+=(
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex !gnutls)
+ )
+ else
+ mycmakeargs+=(
+ -DENABLE_GNUTLS=OFF
+ -DENABLE_OPENSSL=OFF
+ )
+ fi
+ cmake-utils_src_configure
+ }
+
+ multibuild_foreach_variant myconfigure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake-utils_src_compile
+}
+
+src_test() {
+ [[ ${MULTIBUILD_VARIANT} = shared ]] && cmake-utils_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake-utils_src_install
+}