summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/lzo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/lzo')
-rw-r--r--dev-libs/lzo/Manifest1
-rw-r--r--dev-libs/lzo/lzo-2.08-r1.ebuild48
-rw-r--r--dev-libs/lzo/lzo-2.08.ebuild43
-rw-r--r--dev-libs/lzo/metadata.xml9
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/lzo/Manifest b/dev-libs/lzo/Manifest
new file mode 100644
index 000000000000..72cf912fe973
--- /dev/null
+++ b/dev-libs/lzo/Manifest
@@ -0,0 +1 @@
+DIST lzo-2.08.tar.gz 589045 SHA256 ac1b3e4dee46febe9fd28737eb7f5692d3232ef1a01da10444394c3d47536614 SHA512 d03ae521000d69dd1fc92112a7b6e642c388b2898d7fb6ac4168e947a895e8d5e77199f78f05e036cefe02f346ea242bca694522f3c7959ab6ca19de956162dd WHIRLPOOL bea0357b01cb64018a5afc7b0934065dda944866aa23f44edd4eb615d53c0242b70c836d2d8144ed64df4a438bea5c1b8b5120ee4a7f08af15db171f85c11ac8
diff --git a/dev-libs/lzo/lzo-2.08-r1.ebuild b/dev-libs/lzo/lzo-2.08-r1.ebuild
new file mode 100644
index 000000000000..616c15716c88
--- /dev/null
+++ b/dev-libs/lzo/lzo-2.08-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal toolchain-funcs
+
+DESCRIPTION="An extremely fast compression and decompression library"
+HOMEPAGE="http://www.oberhumer.com/opensource/lzo/"
+SRC_URI="http://www.oberhumer.com/opensource/lzo/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples static-libs"
+
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
+ )"
+
+DOCS="BUGS ChangeLog README THANKS doc/*"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && gen_usr_ldscript -a lzo2
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ rm -f "${ED}"/usr/share/doc/${PF}/COPYING
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h}
+ fi
+
+ prune_libtool_files
+}
diff --git a/dev-libs/lzo/lzo-2.08.ebuild b/dev-libs/lzo/lzo-2.08.ebuild
new file mode 100644
index 000000000000..a38e9f5974e1
--- /dev/null
+++ b/dev-libs/lzo/lzo-2.08.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="An extremely fast compression and decompression library"
+HOMEPAGE="http://www.oberhumer.com/opensource/lzo/"
+SRC_URI="http://www.oberhumer.com/opensource/lzo/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples static-libs"
+
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
+ )"
+
+DOCS="BUGS ChangeLog README THANKS doc/*"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ rm -f "${ED}"/usr/share/doc/${PF}/COPYING
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h}
+ fi
+
+ prune_libtool_files
+}
diff --git a/dev-libs/lzo/metadata.xml b/dev-libs/lzo/metadata.xml
new file mode 100644
index 000000000000..caaa4ac67bad
--- /dev/null
+++ b/dev-libs/lzo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+</maintainer>
+<longdescription></longdescription>
+</pkgmetadata>