summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/matrixssl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/matrixssl')
-rw-r--r--dev-libs/matrixssl/Manifest1
-rw-r--r--dev-libs/matrixssl/matrixssl-3.6.1.ebuild67
-rw-r--r--dev-libs/matrixssl/metadata.xml5
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/matrixssl/Manifest b/dev-libs/matrixssl/Manifest
new file mode 100644
index 000000000000..0e69ce70f04c
--- /dev/null
+++ b/dev-libs/matrixssl/Manifest
@@ -0,0 +1 @@
+DIST matrixssl-3-6-1-open.tgz 4342141 SHA256 22f1426c61a9d1b699e7ebbb6c14b00c949613f224429702723fd762642985ee SHA512 762c280d1d1b3a729d95a5b6aa3bab31dd7c725c76a47521709f00d2294693c266690e106d2619f2d4c8ece1757eaf0e45fff84a5c1763938317f09fa2ea2907 WHIRLPOOL 2225846e74eb14b76900fd0124039cd594c1887b83dea36d4fdc6737d17c87de85a19f780887d874e2c846e3edf9e4dede56aa081387a7706f20d4d5c6b7c4b9
diff --git a/dev-libs/matrixssl/matrixssl-3.6.1.ebuild b/dev-libs/matrixssl/matrixssl-3.6.1.ebuild
new file mode 100644
index 000000000000..6e2d44e1c2d9
--- /dev/null
+++ b/dev-libs/matrixssl/matrixssl-3.6.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+MY_P=${P//./-}-open
+
+DESCRIPTION="embedded SSL implementation"
+HOMEPAGE="http://www.matrixssl.org/"
+SRC_URI="http://www.matrixssl.org/cgi-bin/dl.pl?agree=1&.submit=DOWNLOAD -> ${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf=(
+ CC="$(tc-getCC)"
+ STRIP=true
+ AR="$(tc-getAR)"
+ DFLAGS="${CFLAGS} -Wall"
+ )
+
+ if use static-libs; then
+ emake "${myconf[@]}"
+ else
+ emake lib${PN}.so "${myconf[@]}"
+ fi
+}
+
+src_install() {
+ dolib.so libmatrixssl.so
+ use static-libs && dolib.a libmatrixssl.a
+
+ # API is exposed from matrixsslApi.h and rest is included recursively
+ insinto /usr/include/matrixssl
+ doins matrixssl/*.h
+
+ local h1
+ for h1 in core crypto; do
+ insinto /usr/include/matrixssl/${h1}
+ doins ${h1}/*.h
+ done
+
+ local h2
+ for h2 in digest hardware keyformat math prng pubkey symmetric; do
+ insinto /usr/include/matrixssl/crypto/${h2}
+ doins crypto/${h2}/*.h
+ done
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/*.pdf
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r apps sampleCerts
+ fi
+
+ dodoc readme.txt
+}
diff --git a/dev-libs/matrixssl/metadata.xml b/dev-libs/matrixssl/metadata.xml
new file mode 100644
index 000000000000..5c40e771595f
--- /dev/null
+++ b/dev-libs/matrixssl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>embedded</herd>
+</pkgmetadata>